Farmwares disappeared and Farmware system not working

Aloha Folks,

I’m not sure when but all of my installed Farmwares have disappeared and I am unable to install any of them again. The logs show an error of “closed”.

I’ve tried resetting the Farmbot but this didn’t seem to help.

Hey, I’ve experience similar things in the past. Did you upgrade to a new FB os Version for instance just before? Which FW version are you running?

The auto-update is on and I am running Farmbot OS v7.0.1 which I believe updated when it came out.

I am unsure how to check Farmware version, I don’t see anything jumping out at me on the device page or the Farmware page. How do I check?

Select the question mark in the black circle next to the Farmware name in the center panel on the Farmware page…
See picture…


@Intelbotfarmer Oh, I see. Unfortunately I am unable to install any Farmware to get to that point. I just have the 3 default of Photos, Camera Calibration and Weed Detector.
From the way @Klimbim worded it, it sounded like you could check the version of the Farmware system itself.

I am still unable to install any Farmware. Any suggestions welcome.

If @Gabriel or someone from the Farmbot team can comment on this I would really appreciate it.
I have finally completed the custom tool I’ve been working on that utilizes a servo and I won’t be able to test it or write Farmware for it until this is sorted.

CS Failed: [install_farmware] - :closed :closed

I haven’t seen this error before. Can you check your disk usage? Is your FarmBot able to sync and access other network resources? I also assume you’ve tried rebooting. If nothing else fixes the issue, reflashing the SD card might.

I am able to sync the Farmbot and disk usage is at 20%. I am not sure what you mean by Farmbot able to access other network resources.

I will try a re-imaging of Farmbot OS and see if that helps.

@Gabriel Flashing the OS didn’t seem to help.

Can you access on your network? The URL should load in any browser. Did the disk usage decrease after you flashed the SD card?

The disk usage went zero after the flash.
And you’re right, for some reason I am unable to access the ‘raw’ URL. If go to the github Farmwre page,, I am able to view it. I can then click on the manfest.json file and view it, but if I click the ‘raw’ button I get a connection error. Same as if I paste the URL into the address bar. I will contact our complex area’s network admin to if something has changed recently.
Thank you for helping figure this out.

@Gabriel Looks like Enterprise Infrastructure Services Branch (EISB) of the Hawaii Department of Education (HIDOE) categorized as “Shareware/Freeware” and blocked it.
They now have white-listed the domain and I am able to access it but our Farmbot still exhibits the same behavior.

EDIT - Maybe I spoke too soon, access to the domain seems to be intermittent.