Fb gen 1.4 Encoder not working


#1

Ok everybody please excuse my grammer and spelling. So i have farmbot 1.4 fully assembled and moving nicely on all axis. But trying to calibrate it i have ran into wall. When i press calibrate it just goes to one side and tries to keep moving as if the encoders are not working. I found a forum that said to make sure i was using the right firmware. It turns out it was using 1.3 so i changed it to 1.4 which i figured would have been my problem
But using 1.4 none of the axis move atall they make noise like they want to but just wont. If i go back to 1.3 they work fine but calibration dosnt. I emailed farmbot they told me to make this post and tag Gabriel. Im not sure how you tag anybody. @Gabriel


#2

You just add an “@” and put in his name, like this: @Gabriel
:slight_smile:


#3

Please see the encoder troubleshooting FAQ. Working through the symptoms and solutions presented will either solve or provide more information about the issue. In your case, if your hardware is v1.4 you will want to keep the v1.4 firmware installed while troubleshooting.


#4

@Gabriel did i not mention i went thru the forum? I stated that it said to make sure i was using thr proper firmware. When i moved to the 1.4 firmware was when i ran into the issue of my axis not wanting to move. They move fine in 1.3 but my encoders dont function. So to sum it up in 1.3 my axis move properly but the encoders dont work. And in 1.4 the axis do not move whatsoever. But every axis does make noise like it wants to move but dosnt. Now if i switch back to 1.3 my axis move properly but the encoders still do not work?


#5

Yes, keep the v1.4 firmware installed while running through the troubleshooting tips in the FAQ to acquire more information, i.e., What does the encoder position display show after a movement attempt? What does the encoder position display show after moving the motors by hand? What results do you get after inverting the encoders? What results do you get after trying the other suggested setting troubleshooting changes?