Genesis v1.4 conection error

My farmbot has a connectivity error and does not connect the Raspberry Pi with the farmduino. Has anyone had this error or could help me? I’ve already tried an older version, beta and alpha version of farmbotOS, none of them connected.

The Farmbot Raspberry Pi cannot detect the Farmduino. Maybe the USB cable is not seated securely at both ends or maybe the Farmduino is not healthy. I would try a new USB cable first.

In the Farmbot Logs, when everything is working, you should see a ttyACM0 in the list of available UARTs.

1 Like

Thanks for the answer @jsimmonds.
I noticed that the stepper driver of the x1 motor were short circuited, is it possible that this damaged the farmduino board? It’s the second stepper driver that I need to replace due to short circuit

@ESFRO there’s a fuse on the Farmduino at the +24V input connector. Schematic id is F1 part id 0287015
Worth checking that out next.
Are any lights on ?

1 Like

The F1 fuse is ok, I also tested an smd fuse near the usb connection, it is ok too.

There is a green light on near the L2C connector and a red light near the reset button that blinks only when turned on.

@ESFRO my query on that F1 15A fuse was irrelevant; my apologies.
I only run a “headless” bot (no motors, peripherals, etc.) so I have no direct experience with

My Farmduino (v1.5) will boot and connect to the Raspberry Pi without any motors attached.
I would expect the v1.4 Farmduino to talk to the Raspberry Pi with that faulty stepper driver card removed.

1 Like

Thanks a lot for the help.

I tried everything and it doesn’t recognize the farmduino. Could you tell me if I can use mega/ramps without adaptations with my genesis 1.4? Can I continue using the motor with the step driver?
We are a non-profit organization, and we do not have enough money available for another farmduino

1 Like

Email is my best advice. Good luck :slightly_smiling_face:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.