Genesis XL camera not detected

Hi All,

Just about completing my installation of the Genesis XL. I have the 2 piece camera. I was advised to check the connector and that did not help. I tried to combine the cables by removing the connectors and soldering the cables matching the colors. Any suggestions on how to test the camera using a mac? a replacement is coming but as an electronics enthusiast i want to try and fix it.

Thanks for any suggestions.


I’ve had the same problem with my Genesis XL 1.5. I have no way of figuring out if the problem is the camera itself or the Y-axis 4-pin to USB extension cable. I too have a replacement promised (no sign of it yet).

I ran into the same issues on my Genesis XL kit. The replacement (a v1.4) fixed my issues and the image quality is far superior to what I could get - sporadically - out of the v1.5 camera.

@happyfarmer Use Photo Booth on the Mac and you should be able to select the USB camera up at the top once it is plugged in, if it does not automatically switch for you. It is MUCH EASIER to use the live camera feed on your Mac/PC to calibrate the camera, as the only thing you can get from FarmBot are stills and they take a while to capture and show back up in the web app.

1 Like

Thanks @CaptMel. Appreciate your inputs. Will give it a try when the replacement arrive(if and when :)).

1 Like

For anyone finding this thread via web search: If you have reason to believe your camera is defective, replacements are available free of charge to FarmBot customers. Please contact with your order number for information on how to receive a replacement free of charge.