Impossible to connect to WPA3-SAE/WPA2-PKI mixed network

After we moved I had to install a new router (Zyxel AX7501-B0). I’ve set up my 2.4Ghz Wifi as a WPA3-SAE/WPA2-PKI mix type (both WPA3 and WPA2 available). While setting my FB up I experienced that there is no lock shown in the “Configure Wireless” page. So I was unable to enter the credentials because it doesn’t ask for it. After switching to WPA2-PSK only it worked.

Just wanted to share that here if anybody else experiences that. Maybe the documentation should also be updated.

@masze We’re just now starting to see this. Does your router by chance offer a ‘compatibility mode’ option? That seems to help in the limited number of cases we’ve seen this come up.

We use a third party networking library and last time we checked, their support for WPA3 was still a work-in-progress. I will need to check back in to see if WPA3 is supported yet.

1 Like

Unfortunately not.

Curious to test my AP ( ASUS ZenWiFi AX ) with WPA2/WPA3-Personal setting and the Express bot re-associated and connected Ok.

Did find these curious logs, however. ( My Regulatory Domain is AU )


Completely wrong scenario, sorry !

Tested Factory Reset and ( same as you ) see no :lock: for that AX router with dual auth enabled :confounded:
Looks like a bug in FBOS easily fixed, though. Logged in to FBOS with Configurator running
and WPA_CLI shows this for “IoT” ( 3-node mesh )

iex(farmbot@farmbot-84e5.local)18> cmd 'wpa_cli -i wlan0 -p /tmp/vintage_net/wpa_supplicant scan_results'
bssid / frequency / signal level / flags / ssid
3c:7c:3f:40:ae:f1       2442    -11     [WPA2-PSK+SAE-CCMP][WPS][ESS]   IoT
f0:2f:74:28:b6:01       2442    -31     [WPA2-PSK+SAE-CCMP][WPS][ESS]   IoT
f0:2f:74:28:6b:70       2442    -34     [WPA2-PSK+SAE-CCMP][WPS][ESS]   IoT
5c:a5:bc:9a:da:a5       2412    -40     [WPA2-PSK-CCMP][ESS]    IoT-1
[ . . . ]
  • edit
    Interestingly Windows 10 Pro latest version has trouble with dual auth on that router :slightly_frowning_face:

— final edit —
@RickCarlino is 100% correct ( yet again :smile: )

This issue belongs with the VintageNet team to fix . . ( I just chased it down to their code )



@masze there is a simple workaround to get your Farmbot connected :slight_smile:

On the Configurator page where you are given the WiFi SCAN list, don’t select any SSID but use MANUAL INPUT

Enter your SSID and your password ( or the encoded hex-string passphrase ) and you should get connected using WPA2-PSK :tada:

Worked for me with an Express bot on that ASUS router with WPA2/WPA3-Personal in effect.

In truth, not really a Windows 10 issue, I suppose.
My ( ageing ) Surface Pro 3 may need a newer WiFi driver ( Marvell ) :slightly_frowning_face:
I have no trouble with my Surface Pro 4 connecting using WPA2-PSK.
Haven’t tested whether WPA3 (only) works yet.

1 Like

That’s what I would have tried if changing to WPA2-PSK only wouldn’t have worked. But thanks mentioning it. :slightly_smiling_face:

1 Like

Submitted a new project Issue just now :slight_smile:

1 Like

UPDATE: It appears that the Raspberry Pi Linux kernel maintainers still have some work to do on their end. We will be closer to supporting WPA3 once this is resolved.

That’s true but FBOS needs an updated VintageNet WiFi version now to address the Original Post issue . . ( which is not about any problem using WPA3 security ).