Introducing FarmBot OS


#1

Hi all,

Heads up: we’ve recently released an entirely new repository for, and way of setting up the Raspberry Pi. The new repo is called FarmBot_OS and its just what it sounds like: an entire operating system with all the FarmBot goodies built-in. Check out the installation instructions in the readme: https://github.com/FarmBot/farmbot_os#first-time-installation

Essentially nobody will need to install Ruby or clone git repos or anything anymore. Just flash the OS onto an SD card, plug it in, turn on the pi, and use the nifty wifi-configurator to setup your FarmBot (connect it to your home wifi and to your web app account).

This system also features over-the-air updates, so you can now install arduino firmware and controller updates right from the web application! Its really cool :smile:

Let me know if you have any issues getting it set up.


Farmbot OS Availability
#2

#3

@ roryaronson

Rory,

The instruction indicate downloading an .img file and writing this to the sd card. I apologize for my ignorance, but there are no .img files in the download. Please explain?


#4

Ah, sorry - it looks like the very latest release (2.0.4) doesn’t have the .img file. I’ll let the developer, Connor, know. In the meantime you can download 2.0.3 (just scroll down the page a bit)

Here is a direct link to the 2.0.3 .img file: https://github.com/FarmBot/farmbot_os/releases/download/v2.0.3/fw-v2.0.3.img


#5

@ roryaronson

Rory,

I’m working with NWTCTGiese on this project that we’re trying to keep student lead. First let me apologize for being new to the Pi world and thanks for uploading the new img file.

I tried to load this per the instructions on the other website and no matter what img file I try the Pi gets stopped at a line “random: nonblocking pool is initialized”. I’m not sure what to do about it. From another search I found that it had to do with trying to run a cmdline.txt line of code and I by no means am qualified enough to hack into your img file. Any help or direction I could get would be greatly appreciated. Thanks!

-Joe


#6

Hello. The issue i expect you are having is not caused by random: nonblocking pool is initialized that is just the last message the linux kernel sends on bootup. There is no real GUI to be displayed on HDMI and there have been reports that having an HDMI device plugged in actually breaks a few things. Heres what you can do:

If you would like you can follow the bug progress over here: https://github.com/FarmBot/farmbot_os/issues/186


#7

Hello I am using a mac and recently deleted the raspian os I had on my pi 3 reformatted SD card and have installed the farmbot os from the last link provided https://github.com/FarmBot/farmbot_os/releases/download/v2.0.3/fw-v2.0.3.img9

I have read over and over to make sure I did not miss something but the instructions for mac are not to clear to me as the instructions are as follows
Linux / OSX / UNIX
dd if=img_file of=/dev/sdX
where img_file is the path to you .img file, and X is your device’s drive letter.

The way I installed the os was download the .img file and put SD card in my computer after downloaded I dragged the .img file to the SD card and later when I put in my pi nothing happens.

The Farmbot OS is not working on my pi 3 as when pi is powered up nothing happens and red LED turns on but thats it, no wifi networks showing like instructions state. I was hoping I could get some tips or help on installing the Farmbot OS on the SD card for a SD card in a mac.


#8

You will need to use the command line to write the .img file onto the SD card. This is not the same as just dragging the .img file onto the SD card. To do this, you will need to use the command as follows:

dd if=img_file of=/dev/sdX

where img_file is the path to the FarmBot OS .img file, and X is your SD card’s drive letter. You should be able to find out both of these by looking at the info of the .img file and the SD card I think. I don’t have a mac though so I’m not exactly sure.


#9

I’ve tried several versions of this image file on my raspberry pi 3. I have no problem booting it up and connecting to the wifi configurator, but from there I have no success. I get a list of all my wifi spots, but when I select a wifi network and type in the password and login information for my.farmbot.io, all that happens is that the browser jumps to the top of the page(tried this with several different browsers). No error message, no dialogue.
I can see from my router that the Pi does not connect to wifi. Connecting through an ethernet cable has the same effect, as I cannot connect to the my.farmbot.io account.
edit: latest version i tried is 2.1.2
edit2: ok, atleast now I get wifi connection with another router. Some action on the farmbot page, as it shows the correct OS version (2.1.2), but no movement on the steppers through my ramps board(error messages, failed/“farmbot didn’t get that”).
edit3: And now it’s a success. Connected though ethernet and I can control everything on the my.farmbot dashboard, including steppers. Not sure about the exact source of the problem, but I think it was a port forwarding issue on my router.


#10

Thanks for the feedback Martin and sorry for the troubles. I’m glad you got it all working. We have heard of some other issues with wifi routers. If you get any more information about what the issue was please post it.

On a related note, it has been an ongoing issue for us when people have/are using different versions of the frontend, backend, and the OS/firmware. We’re working on a way for users to keep the codebases on compatible versions, like in this PR: https://github.com/FarmBot/farmbot_os/pull/195

Ideally once the codebases stabilize more they will stop becoming incompatible with each other as often.


#11

Thanks. This is nothing compared to what I encountered with the farmbot software back in 2014/2015, so you’ve come a long way. :smile:
Looking forward to play around with the system again, and I’ll give a shout out if I get any meaningful insights along the way. :slight_smile:


#12

I am a volunteer lead on a high school and college student based project intending to use farmbot. My programing skills are limited. I would appreciate a youtube tutorial for novices on the download, installation and use of the farmbot programs using a mac.


#13

Hi Richard,

You can see install instructions here: https://github.com/FarmBot/farmbot_os#installation

Once you install the OS then follow these steps:

  1. Plug your SD Card into your RPi3
  2. Plug your Arduino into your RPi3
  3. Plug your power into your RPi3
  4. From a WiFi enabled device*, search for the SSID FarmbotConfigurator
  5. Connect to that and open a web browser to http://192.168.24.1/
  6. Follow the on screen instructions to configure your FarmBot. Once you save your configuration FarmBot will connect to your home WiFi network and to the FarmBot web application.

*If you are using a smartphone you may need to disable cellular data to allow your phone’s browser to connect to the configurator.


#14

Hi everyone,

I recently installed Farmbot OS on my RPi3, it was pretty straightforward and easy to configure. Thanks for the great job.

When connecting to Farmbot Web I can see that my wifi network was configured well, I can see it with an nmap on my local network and also on Farmbot Web (Logging from Farmbot ntp: :ok to WIFIMANAGER(WLAN0, ASSOCIATE_WIFI) GOT EVENT :IFUP).

However the connection is not working really well because I can often see the following message :
Warning Could not fetch bot status. Is FarmBot online?

Because of this connection issue I cannot install the arduino firmware through FarmBot Web :
Farmbot Didn’t Get That! Check for Updates request failed.

I tried to install different versions of FarmBot OS, it was not working with 3.0.1 but I had these better results with 3.0.2

Sometimes it is working better and I could see different messages :
Farmbot is getting kind of bored zzz
Farmbot is downloading:
Farmbot is finished downloading

However most of the time it is just not able to fetch my bot information.

Is there any way I can see the local logs on my rpi3 ? When I connect with ssh to the rpi3 the farmbot os version of linux is very limited, nothing in /var/log/ so it is very hard to understand my network issue.

Thanks again!

NB: I also tried to install directly the arduino firmware and when compiling the current master branch I had to comment out the line //motorEnabled = false; of StepperControl.cpp since it was not declared


#15

I found out my problem I think. The version 3.0.1 of FarmBot OS was not working but the staging version 3.0.2 is working well for me, The point is that I had to select the staging server during the wifi configuration (click on the + and then write http://staging.farmbot.io). Everything is fine on the software part for me and I can start to test the machine now :slight_smile:


#16

Can you please give me some features over raspbian os. I am looking to install on my raspberry pi 3. So, FarmBot is better option or not.


#17

There is no longer an option to install FarmBot software on Raspbian. Instead, flash FarmBot OS onto your SD card and it includes everything you need for the device to operate.


#18

good afternoon
tell me how to connect the camera raspberry and configure it
Thank you


#21

Has ssh been removed?


#22

Hello I have a problem with my farmbot bone I have to flash the image on the SD card I successfully connect and configure but the problem is that I can not get the terminal on the screen Or is bracing the raspbery pi and when I logged in ssh it asks me for a password with as root user