Issue with home after upgrade

Hi @RickCarlino

Is there an issue with the bot finding home after the upgrade? For some reason, my bot thinks home is at random spots along rails. I have to do more troubleshooting but wanted to see if there was anything related to quiet mode or the new version that I applied. I think I recall a microstep problem before?

1 Like


Is this happening all by its self, or is it happening after running FIND HOME?

Enabling quiet mode on a preexisting account might change motor behavior. We’ve already seen a few instances of folks switching to silent mode and needing to change motor tuning values. My recommendation would be to reset all calibration values and start fresh to see if that helps any, assuming that you have modified default values.

Additionally, we’ve recently changed the default motor current value from 600 to 1000.

Hi @RickCarlino

It’s happening by itself in the middle of my watering sequence. It seems like it stalls but instead of stalling, it says it’s stopping at another location for x or something like that. I just disabled quiet mode and changed the current to 1000 to see if that helps.

@stre1026 That’s a strange one that we haven’t seen before. I’m going to ping @Gabriel about it to see if he has any ideas. Please let me know if disabling quiet mode (as well as a power cycle helps).

The only time I’ve seen this happen before is:

  • If the app is open in two tabs
  • If two devices have been configured to the same account (extremely unlikely in your case, I think)

I will let you know if we find out anything.

Actually, on second thought @stre1026:

This might be much simpler than that. Is it possible your device’s LENGTH setting got borked due to a bad FIND LENGTH or FIND HOME operation? If that’s the case:

  • Power the bot down.
  • Ensure you have a reasonable length for X/Y/Z
  • Power the device back on.
  • Inspect the device for the issue again to see if the problem went away.

Generally speaking, if you get a message about “Stopping at ___ instead of specified location” that means that FarmBot thinks it is already at the end of the axis already. This can happen if you ran find home and the bot got caught on an obstruction rather than the end of the rail.

1 Like

Hi Steve (@stre1026 ),

I am having the same problem when I enable Quiet Mode. Have you been able to find a solution?


Hi @ClosedCircuit

The jury is still out whether this fixed the issue or not but I changed the current of all motors to 1000 and loosened my rails a bit. We’ve had quite a bit of rain as of late so I think my raised bed is expanding and contracting a bit. @RickCarlino can correct me if I’m wrong, but I believe you lose a bit of torque in the motors when you enable quiet mode so I think it’s even more sensitive to rail problems. I may be wrong there.

1 Like

I am unsure if quiet mode makes the motors weaker or not (have not had issues on my setup) but it definitely changes the tuning behavior. Since silent mode does indeed interact with other firmware settings, it might be best to start fresh on a new set of firmware configs, especially if you have a bot that’s been running for a long time:


Please let me know if a reset helps. So far, the biggest issues we’ve seen are current values that are too low, or non-default microstepping values.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.