Issue with Z up moves while planting

So, finally a sunny day, and I am trying some robotic (Express) planting but not getting very far.
Several concerns:
1: when I reset home, the z-axis raises to the stop backs down about 20mm then goes back up but stops short of the stop by about 10mm. My other bot returns to the Z Stop. I guess it is not an issue if it remains consistent. But it might be related to the following problems.
2. when running a planting sequence, the unit drives down to 50mm above the tray, turns on the pump, drives down (at 80% speed), picks up a seed but then doesn’t go to the 50mm up as instructed. It makes a couple of short attempts but then stalls after. only going up 12mm. (I have tried this several times with the same result.) It also gives the error

Problem sending RPC command: no match of right hand side value: {:error, “Movement failed. Z axis stall detected”}

  1. This maybe is a software issue, after the above stall, a send to home does not raise the z-axis but drives the axis back down and then up as if it was already home. It doesn’t seem to stall and then resets the y and x axis (bending the needle a bit).
    A second attempt to reset home does raise the z-axis. (no stalls on that up move until it hits the stop).

I hadn’t modified any of the stall parameters for the Z motor, the Max Motor Load was at 70 and the Grace Period at 100. I changed the Max Motor Load to 80 that helped with #1 problem but not consistently. I tried 85 which gets through the planting seed sequence for more than one seed but it spends a lot of time trying harder to move the z above the stop and repeats 3 or 4 times. So, I have reset back to 80.
After noticing the Your topic is similar to… per the “Z-Axis [Up Movement] Issue” I changed the motor max speed and the Accelerate numbers (different units from notes) but nothing seemed to help much.

@dlmcshan Motor issues can be tricky to debug. @Marc will be in contact with your shortly to address the remaining issues.