Local server setup - Ruby version is 2.7.2 but your gemfile specified ~> 3.0.0


Hi Rick, the spring time is coming around in the Northeast and I am taking another stab at the SSL certificate project we worked on last year. Hopefully with fresh eyes, I will be able to get this solved this year. It worked fine last year without SSL but I still want to try and figure this out!

I built up a brand new Ubuntu 20 server and am following the updated install guide on github but I’m running into an error that says “Your Ruby version is 2.7.2, but your Gemfile specified ~> 3.0.0” I’m not sure where this is coming from. This is happening when I run the " sudo docker-compose run web bundle install" step.

I’m sure this is something simple but do you have any ideas?

@stre1026 I’ve been meaning to fix that one for a while, but never got to it because our setup is Dockerized. That is to say, although it is unsightly (and should be fixed), it shouldn’t actually stop anyone from running a server- is that the case on your end? Please let me know if that’s not the case. I can push up a fix later today or before the end of the week.

PS: do you use Github? That might be a better place to have more technical discussions. If you don’t have a GH account already, that is fine, we can continue the discussion here. The reason I mention it is that GH is often a starting point for developers when entering a new codebase, so having this discussion in an issue thread rather than a forum post might help future developers. On the flip side, there’s no need to create a GH account if you don’t have one already. :+1:

1 Like

@stre1026 I stand corrected. You probably are (like me) running an old version of RVM. You might be able to fix the issue via:

rvm get stable

@RickCarlino It’s funny you mention GitHub because I hadn’t had an account over there but just created one the other day (with this same username) for something else I was toying with. I will certainly take these matters over there if you’d like.

I can try that rvm get stable but I assume I need to run that in the container? If that’s the case, the container won’t run at all because I can’t get to that point.

@stre1026 You might have a different problem than me if you are totally unable to start the app. I would be interested to see a full error log.

@RickCarlino I’ll try again tomorrow but I can’t even start the app. It’s when I go to build the containers that I am getting the error about Ruby. I don’t recall having this problem the first time I built the server last year.

1 Like