Major Gantry issues

My students and I bought one of the first Farmbot XL kits last year. Our bot is outside and at the beginning of May we started back up again when the weather was nice. We have NOT been able to get the X axis to move correctly at all. On the lest side the belt keeps rolling up on the wheels and stopping the entire side from moving. This issue has made the entire bot useless - again. We have been having issue after issue with this kit and my students are getting completely fed up with nothing working. Please let me know what I could do to fix this issue.

Hi Saratate,

I have had lots of gantry issues as well but I am slowly working it out. I now have it to a point that it is quite reliable.

My main issue was the eccentric spacers were not adjusted properly. After setting them to the loosest possible setting (the 6mm mark facing away from the extrusion), it rattled a little but didn’t fail in its movement anywhere near as much. I then tightened them a tiny bit and the rattling went away.

With the issue you described, you may want to check that the belts are not twisted inside the vertical extrusion section of the gantry. You may need to undo the belt and feed it back through, taking care that it doesn’t get twisted. That is vital. The tension of the belts is also important. They need to be pretty tight but not so tight that they are stretching or anything like that. I would say pull them tight and then back it off a little.

The speeds that you set the movement at and the acceleration lengths are also important. You can set these in the device tab. These setting are working pretty well for me at the moment.

I also found that setting the speed in the actual sequence is also important. Notice the speed on here is set at 60%. I assume that’s 60% of the speed that I set as its max speed in the device settings. It moves slowly but after months of unreliable movement, I’ll take slow over a failed movement anyday!

You will also need to grab a measuring tape and check that your rails are parallel. If the timber they are attached to moves, they will be out of alignment and it will fail. If they are not parallel, use some shims between the mount and the timber to align them.

I also work in a school and I know as teachers we are time poor and the farmbot is certainly a machine that requires lots of tinkering to get it going. If you can muster the enthusiasm, stick with it because it is quite rewarding when you finally get it working. I received my farmbot kit in November last year and have had it working properly for the last couple of weeks.

Best of luck with it. Take a deep breath and try not to get too frustrated :slight_smile:


1 Like

I think @markgregory8 has given solid advice and a great place to focus your efforts.
I just want to chime in with encouragement and moral support.
We have been “doing FarmBot” for some months now, and we have had many challenges and experiences. I could have become dismayed and disappointed. In fact, at first I did. However, after a bit, i found that I actually welcome the speed bumps. Each time, I pull in some students, some teachers, some parents, and we all work on the issue at hand. This device has provided so much. Forget the fact that the crop this year may or may not be a bumper crop. It is all par for the course. We now have so much to do before the next growing season!

Please hold on and seek out us, the FarmBot Forum Folks when it seems dark. We will, at the very least, offer understanding, and, at best, solutions, ideas and resolution.

Be well, @saratate :smile:

I also have had similar issues in the beginning. The problem was mechanical, but not the gantry width or straightness - it was the X axis rails not being very very exactly level. Take a water bubble level and hold it vertically against the rail, and make sure to adjust your rails to be fully level in that direction too. After doing this I suggest that you check once more that the gantry width is correct (because even slight adjustment of the vertical rail orientation has a significant impact on the upper part of the gantry)

1 Like

Same here - lots of problems until we leveled and aligned.
We found the using just sight (looking down the rail form either/both ends) provided the insight to better straighten the rails. We used wood shims on each of the mounting brackets to move the rail until it was straight for the entire length.
Also, the belt thing sounds much like ours did with mis-allinged rails.
And, as @markgregory8 said, slow everything down. FarmBot has all day and all night. No need to rush… :slight_smile:

These are really great suggestions, but they are all things that the students and I have gone through before. The rails are straight and level and the belts are not twisted, yet the belt still jumps the wheel on the X-axis making it so that it cannot move with out assistance. Our autonomous robot cannot be left alone to run at all. If there are any other suggestions that can fix this issue I really need some ideas before going over to the farm today. Honestly at this point one of our other adults is suggesting completely remaking parts - making the kit we bought worthless and a fraudulent product.

Can I ask you to put together some pics and some videos ?
If you can capture the fails we can probably get an idea of what is going on.

I’m taking the students over in half an hour. I will get some video.

1 Like

I will check the forum often today…
Btw - making parts to work around or modify or make the bot better does not nessraly make make your bot a fake.
We all do “stuff” to get our bots working in our worlds.
If you could gather the following images & clips:
1). The belt riding up on the wheel.
2). A pic down each rail. Put the gantry at the far end and get the camera as close to the rail as you can. Bonus points if you can from each end of each rail.
3). Remove the belts and manually move the gantry from one end to the other. Use two people so you can keep it in line.
Did you feel any ressitance?

Also, using a tape measure, measure the distance between the two x-axis rails at a few (5 or more) points down the length of the x-axis.
What geo/time zone are you in?
And, since you have the belts off, inspect for damage. We toasted a set on ours in the early days, too.
If your not sure, have two students hold the ends and pan a video down the lengths. Do both at the same time. Teeth facing up, camera off to the side to show profile.

Hi all,

In addition to measuring the x axis, measure the distance between the two vertical extrusions on the gantry at the top and bottom. If they are not identical then it will be twisting the frame and binding on the x axis extrusion.

It’s a real pain but I undid the bolts that connect the y axis of the gantry to the vertical parts and it sort of sprung in towards the middle a little bit. I had connected it so that they were right at the end of the y axis extrusion but that was incorrect as my x axis rails were not that far apart. Whilst it looks good, the y axis distance must be the same as the x axis separation.

Another thing I had trouble with was the x axis belt stops. They need to be exactly level with each other. Naturally I wanted it to be pretty so I put each one right at the end of the x axis extrusion. Unfortunately that didn’t mean that they were even with each other. When I homed the machine, one side would arrive at an end stop about 5mm before the other. That meant that the gantry was not equalised and effectively twisted before I tried any movement on the x axis. This made it fail as soon as I tried to move it. Try moving the gantry by hand in the middle, just with one person and move it really slowly until it hits one of the belt stops. If it’s not hitting the other one at exactly the same time then it will fail.

Controlling the bot with the control panel also means that when you move it say 1000mm on the x axis, it is moving at the max speed and acceleration values you have set. Until I slowed it right down, mine failed every time.

Another issue I had was I had put the gear on the motor at the top of the gantry right up against the aluminium extrusion. It should be a few mm away to be in line with the belt properly and so that it doesn’t bind on the extrusion. Also, test that the gear is not slipping by wiggling it by hand. Undo the belts and run it on the x axis. Make sure the gear is spinning true. If the motor axel is bent, that won’t work.

I also read in the documentation somewhere that it was possible to bend the ‘axels’ on the wheels that attach the gantry to the x axis. You may need to check for damage there too, in addition to belt damage as @Intelbotfarmer suggested.

I’m determined to get to the bottom of your issue. I think the farmbot design is generally a solid one but it has quite a few issues. It is trying to do something that is very difficult and has lots of things that can go wrong but I think making other parts to solve your problem is unnecessary and more of a hassle than fixing it.

I know you can’t see it now, but I think your issue will be solved in the next 7 days :slight_smile:


1 Like

I’ll monitor as well and chime in if I have something to offer - looking forward to the videos. . .cd

Today we took some video. The kids measures the X-axis along the rails and the vertical extrusions are parallel. We are in the Chicago time zone. When the belts are removed, the gantry moves freely both ways with little to no resistance. At this point we are wondering if it may be an issue with the motor.

Here is the video:


Your video looks very familiar. I can imagine that the problem is exacerbated by the XL version. I have the smaller machine and it was bad enough! I have my machine moving even more slowly that that. I have also had problems when I press home rather than a movement that I just tell it to move 1000mm on the x axis with the control panel.

The video shows the problem and what you’ve tried to fix it already but it’s difficult to diagnose without close up pictures / videos of the mechanism. I know you said the kids measured the rails but kids are notoriously unreliable. Double check their measurements if you could. Mine was 3mm out and that caused it to fail. They need to be pretty much exact.

You’re right to think it could be a motor issue. If it is a motor issue, it is more likely what is driving the motor rather than the motor itself. I read somewhere that the stepper motor drivers at the top of the farmduino board are replaceable. Could try changing the x axis ones with the y and z axis ones just to rule that out as an issue.

To help diagnose the issue, it would be good to see:

  1. The gear on the motor at the top of the gantry on both sides, with the belt on and off, in use and just turning it by hand.
  2. The plates where the wheels join the gantry to the x axis extrusions. If you take the gantry all the way off the extrusion, does it slide off easily? When I did that, the wheels moved in, telling me it was too tight. In the manual it says you can use a spacer to make them even looser than having the 6mm engraving pointed toward the ground.
  3. The actual belts themselves at both ends. What happens if you put your finger on the belt? Is it vibrating a lot when the bot is moving? Can you push it down at all? Is it flat i.e not at an angle.
  4. Inside the electronics box to see if the lights flicker at all. If you grab a multimeter, you can test the voltage in the system by putting one probe in one side of the fuse and the other probe on the USB connector of the farmduino board. It should be close to 24V the whole time. If it drops, the power supply could be an issue.

If it’s not a major problem, could you post videos / photos of all of those parts of the machine? There doesn’t seem to be a lot of room for error with this design so it all needs to be really really accurate.

I hear your frustration and you’re not alone. I spent weeks over summer tinkering with it and if I could have picked it up and thrown it, I would have. I still get that every time it stops but it’ll be worth your efforts.



Thanks for the vid clip - it helps to highlight your issues and gives me (and I am sure others) ideas that we can use to help. Before I give feedback on your current challenge, I would like to give some feedback on where you are today and the frustration and disappointment that you clearly show in the video clip. I know how frustrating it feels to put in all that effort and have things not work as designed. Nothing worse than flipping the switch and not having the light go on.
Looking at the video, I see SO much that you and your team have accomplished! You built a HUGE raised bed! You moved mountains of dirt! You built a ROBOT!
You have all the pieces in place, and you and your crew should feel VERY proud of that!
I know (all the “FarmBot-ists” out there know) how hard, complicated and challenging what you have done so far is. I know that your frustration is at a peak right now, but try to take a moment, forget about the challenge you have today, and just reflect on what you have done so far. You are all engineers, designers, up-and-coming programmers, modern day farmers, and future mad scientists!
Ok, now let’s get to it!

What i see so far is a very good start, with some debugging and tweaking needed, but TOTALY resolvable. @markgregory8 said 7 days… I think 5!
(But you have to do the work, we can only give thoughts and feedback (and tons of support!)
FarmBot is not just an item that works out of the box - with it comes learning, exploring, tweaking, and tinkering. And, most important, a community of like-minded folks willing to help and with your team.

So, I will chime in with my debug advice…
It looks like you already have the lions share of assembly done - Congratulations!
It looks like you have the network connectivity done - Super Congratulations! (This is huge!)

So, I would start with “fault isolation”.
Let’s try just getting each motor to spin, without the other ones. Can you release the x-axis belts and the, with the WebUI on the Controls tab, just try moving on the x-axis? Do both motors spin?
Reply back with your findings…
And know that we will help…


Even if it’s not clear to see the issue, Mark and Tony are providing great suggestions in my opinion.
First thing to start is, as both already wrote, to see if both motors are rotating at all. There could be an issue from the stepper driver. Maybe there is just not enough power (current adjustment) which would cause the motor to stutter. Thats just a thought, since we did not see/feel the motor behaviour directly.


We want to help you with your FarmBot issues. Can you take some close up video to show the motor moving and how it is interacting with the belt. This will allow us to actually see what the problem is. We need to see what is happening close up to understand the issue.

We have also prepared a troubleshooting guide specifically for these issues:

We need to get a look at your motor settings. Can you take a screenshot of your motor settings under the device tab:


1 Like

How are you and your team doing?