Motor Max Speed


I just got my Genesis v1.6 built and working. I was experimenting with the max speed of the x-axis but was not seeing a change in speed. The default value was 80mm/s and when I roughly timed the 1000mm it took 12 seconds. I then changed the number to 160mm/s and it still took 12 seconds to go 1000mm, I tried 300mm/s and still the same 12 seconds. What am I doing wrong?


Somehow, you wouldn’t have the axis mixed up would you? Maybe plugged into the wrong spot or something? I’m only guessing as to how Farmbot steppers are driven, but if they use pulses like a CNC machine, or 3d printer, then the greater number of pulses should produce a greater speed, unless the stepper stalls, and that would be obvious.

No, I have the correct motor. I tried the same test on the y-axis as well, it is just easier to work on the x-axis as it is longer

@tvromero Welcome :slight_smile:

Similar ? Different ?

Is the X-axis moving at max. speed anywhere in that 1000mm travel ?

No different speed on the y-axis as well.

The x-axis accelerates but there is no change in max speed

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.