Motor speed dont change

i’m trying to change the speed of my farmbot genesis 1.4 but it always seems to be at the same speed, no matter what value i put in the settings, the speed doesn’t change it just changes when i run the find lenght command. is anyone having this problem?

Hi @JoseRoberto and Welcome !

Can you show which Motor parameter you are changing and which Axis ?
How are you testing after setting the new parameter value ?

Some Motor Speed parameters apply only to very specific operations.

Here are my settings, as an example

I tried to change it in all possible places, without any result, every value that I enter results in the same speed.

these are the current parameters, however it is moving at 120mm/s in every axis.

motor

Hi @JoseRoberto thanks for that picture.

Farmbot axis movement maximum speeds are many times slower than a typical 3d-printer !
This fact is due to the hardware design of the robot; gantry mass, axis rail and cable duct frictions, motor size, etc.

I haven’t been able to find a general number for expected maximum axis speeds or the maximum step pulse rate per motor out of the Farmduino and the stepper drivers used.

There are many Forum Topics and posts about setting reliable Axis motor speeds, e.g.

Also check the on-line Documentation, e.g.

Might be worth setting your motor parameter values to Defaults and then changing one parameter at a time ( in small differences ) to find the Maximum speeds for your machine.

Thanks for the tip, I’ll try.

What is strange is that when I execute the find length action, FarmBot moves at an acceptable speed.

@JoseRoberto What firmware-hardware do you have ?

That shows that 80 mm/second is reliable for the X and Y axes.

I have genesis 1.4 hardware with firmware 6.6.22

test

@JoseRoberto due to limitations in how our firmware is written, the maximum speed the Arduino can pulse the stepper drivers for normal movements results in max speeds of about 120mm/s for the X and Y axes with the stock belts and pulleys and somewhere around 24mm/s for the Z axis with the stock leadscrew. Setting the MAX SPEED higher will not have an effect, sorry this wasn’t made clear in the app.

1 Like

@roryaronson Thank you very much for the information!

is there any tutorial on how to compile and flash a custom firmware ?

would it be safe to increase its speed to something around 180mm/s?

Here is some knowledge that I have gathered over the years while playing with CNC conversions on lathes etc.
Stepper motors in general have some very definite limitations.
A stepper motor’s strength decreases with speed, so the faster you run a Stepper motor, the less power it produces, and the easier it is to stall the motor.
The strength of a Stepper motor is dependent on the voltage supplied to the motor.
With the Farmbot, there is a definite limit to the speed that the stepper will run at, and that speed limit is probably based on the capabilities of the motor, the power supply and the driver chips installed on the main board.
When Rory designed the Farmbot, he would have taken all this (and probably more) into account.
I’m guessing that the goal was to design a machine that would work reliably and to allow for movement despite unforeseen events, such as some part of a plant etc, obstructing movement of an axis.

2 Likes

We do have a tutorial for using custom firmware, and here is the firmware source code. I don’t believe it will be straightforward to increase the maximum stepping speed the firmware can output because I think you will run into clock speed limitations, though you are welcome to try!

And also, as mentioned by others in this thread, you may run into other issues trying to go that fast because FarmBot is a much heavier and larger machine that say, a 3D printer, so it has a lot more mass to accelerate and move around.

1 Like

Thank you very much