Motor stutter and won't stop after calibrate

Hello, i’m having an issue that happened right after i auto calibrate the Farmbot. The encoder is working fine and the motors is working fine too.

After the calibration proccess done, the motor wont stop and keep hitting the stopper until i press the e-stop button, so i never saw the “calibration in X done” in my log, instead i got “calibration X: idle”

The same thing happened when i press “go to home” button. They keep going but not at the full speed. This problem happened in all axis.

Here is the video of my motor problem :

Any response is appreciated :slight_smile: thank you in advance! :smile:

and this is the log after I calibrate the bot

Two troubleshooting tips that may help identify the issue:

  • What are your encoder settings (in the Hardware widget), and what are the resolutions of your motors and encoders?
  • What position is reported in the Controls page Move widget when the axis end is reached? (You can display encoder positions as well if you haven’t done so already using the Move widget settings menu.)
1 Like

Thanks for the reply Gabriel!

  • here is my encoder settings:

encoder bot

My motors resolution is 200 step/ revolution (1,8 deg/step)
My encoders resolution is 360 lines/ revolution with differential output
  • this is the encoder reading when my bot reached the end of the gantry
    encoder end

and this is when my bot reached the other end of gantry

encoder other end

please let me know if I have done anything wrong

Your encoder missed step decay value seems to be really high. Did you try to decrease those values to default (5 I guess)?

1 Like

hello @Ascend I tried to decrease the values of encoder to 5

step decaty

but still no luck :slightly_frowning_face: