Motors not functioning

So, yesterday, I was messing with my FarmBots Express (both of them). I was trying to turn on the "quiet mode’. And having some troubles. I decided to refresh the OS (14.3.0) on both bots. I thought it was working but this morning (after overnight storms). The motors on both FarmBots seem not to be operating. Using the manual controls, I can tell it to move and the app graphics and position readings advance appropriately but the physical positioning are unchanged. There is no noise from the motors.
I have done soft reset/restart/ unplug/replug… nothing seems to help. Same behavior on both bots.
I am out of ideas at the moment. Are there some fuses or other way to enable the motors?


@dlmcshan A few things:

  • Enabling quiet mode changes the way your motors operate. Unfortunately, this means you may need to re-calibrate your motors after enabling the setting, especially if your device has been up-and-running for a long time (before we change the system defaults). If you provide me your device ID I can take a look.
  • Has disabling the QUIET MODE setting helped at all?

I had tried turning it on and off when the feature first came out. Turning it on and trying Finding Home had it spending a lot of time spinning its wheels before setting each axis. I didn’t spend much time trying to “tune” the motor/stall parameters. So I had turned it off.

With the new OS update, I decided to give it another go, but ran out of time tuning before the storms came.

Currently the systems “works" the same with quiet mode enabled or disabled, the motors are completely quiet and not moving.

FarmBot order number: FB5870

Bot accounts are:


One thing I forgot to mention, when I refreshed the OS and was running the setup, I mixed up the bot and e-mail accounts assignments.

I redid both and can now see that they are correct in that I can see the light on top of the controller box turn blinking/solid as I lock/unlock the app and also turning on the water works and is for the correct bot.

NEW TODAY: I checked both bots still with no motor action. On opening the controller box both show a green light above the Z-Motor drive connector on the controller board. Not sure if that helps.

Here is a picture of the controller board lights:

Thanks for the update, @dlmcshan I will take a look remotely in a moment.

same issue here

1 Like

@dlmcshan I checked on your device, but will need to take a deeper look on Monday when the rest of the team is around.

@JollyJoker Please provide me a device ID and ensure that the device is online for remote inspection. I can take a look on Monday. Thanks!

Sorry, but how do I obtain my “device ID”?

@dlmcshan My comment was directed at user @JollyJoker who is having the same issue. I do not need your (@dlmcshan) device ID as I already have that information on hand. I will provide you with updates momentarily.

@dlmcshan @JollyJoker After some investigation, this appears to be a bug in FBOS. We have just deployed a fix. Please upgrade your Express device and let us know if your device is working again. Thank you for reporting the problem.

Okay, motors are functioning again! Thanks!

However, I quickly tried the Quiet Mode; but I am having problems with the X-Axis motion and the Z-motion finding home about 20mm short. I see some mentions of other post on the quiet mode and see if there are answers there first.

1 Like

Mine is working again now, without the quite mode. Should I test quiet mode again or should I rather not use it? It is an amazing feature quite mode, I was very happy with it, because without it, it sounds like the motors will break soon.

@JollyJoker Getting quiet mode working would be ideal. I recomend resetting your firmware values back to defaults and re-running calibration:

  • Quiet mode requires different tuning values than standard mode
  • The factory default firmware values that are applied to new accounts has changed with the release of quiet mode. Since you’ve been using FarmBot for a while, you may have old default tuning values (we do not change firmware tuning values retroactively because it could break functioning devices).

Have you tried re-calibrating the firmware settings in the device settings page yet? Please let us know if you need help. Another option would be to try power cycling the device (unplugging it from the wall) to make sure there are not any old firmware values lingering after the upgrade.

I have turned the quiet mode for both of my two Farm bot express for all axis. All is well, I think and I do like how quiet it is!
I did notice it was having some trouble with finding home. I will work on some on parameter tuning tomorrow.
Thanks again for your help!

1 Like

We’re glad you like the new feature, @dlmcshan. Please let us know if you need any additional assistance.

How are things looking @dlmcshan ? Were you able to get the motors working in QUIET MODE?

Sorry, I thought I sent a reply last week but maybe I forgot to send it.

Yes, I did get Quiet Mode working on both of my FarmBot Expresses. I reset all the parameters to their default values except for the Minimum Speed for all the three axis which I set to ZERO. I think the default minimum velocity was preventing the motor from gradually accelerating causing it to be occasionally jerky (or draw more power getting started).

I haven’t actually tested the Z motion yet with the minimum value. I will run some more tests this week; but both got through watering sequences over the weekend. I did have to start them manually for some reason.

1 Like

Well, today, my robots are acting up again whether the Quiet Mode is on or off. Happens most often when there are multiple axis motion involved. It will make 2 or 3 short moves of only a few centimeters before stalling on one of the axis. (doesn’t trigger lock but stops sequence). I was observing the motor load graphic in the manual controls while doing this test. They didn’t report any load too high for the stall max load but stalled anyway. Maybe a current vs time plot would help, if possible?
I tried increasing the motor current from 800 to 1000 which helped but not consistently and with the higher current wastes a lot of time trying to “Find Home” on the x-axis.
(Still waiting for limit switch parts. Assuming I get them working, I can try cranking the current back up.)

Pretty frustrating getting it to work well one day and hardly work the next day. Maybe I need different parameter profiles based on temperature/humidity or time of day?

@dlmcshan I think something else is going on with your device. To save time, we will reach out to you via phone in the coming days. It seems that there is a very complicated issue at play and it will be difficult to troubleshoot via forum messages.

@dlmcshan I have contacted you privately to continue discussing the motor tuning. Please check your account email address.