password reset fails


being unable to login to, I tried the password reset procedure. I got the mail with the reset link, but the link does not work. The page does not load, i’ve juste got in the bottom bar “waiting for

Tested with firefox and chromium

@nicolas Thank you for bringing this to my attention. I will take a look right now.

I have received reports this week from institutional users that our emails are being blocked. If your email is filtered by an IT department, it is advisable to inquire with them about accidentally blocking FarmBot emails.

I will let you know what I find after investigating this issue.

@nicolas Password resets appear to be working, as I was able to perform a new account signup / password change / password reset on

Please let me know if there are any special circumstances that we should be aware of. My guess would be that your password reset email is being filtered.

Thanks for your rapid answer.

I’ve got the reset mail but the link page does not load.
It’s via a gmail account with Chromium or Firefox.

I tried to cut/paste the link

With chromium I have no browser extensions enabled

Which browser do you use?

I tried too with my android phone (on 4g network and wifi) with 2 different browsers, same problem.

Maybe a trouble with my account? Maybe you can reset or delete it?

To be able to continue, I’ve created another account with another of my addresses

@nicolas I tested it on Chrome with GMail. If you private message me your email I can take a look.

I have a very similar issue. I went to access my account and the system on your end has changed my password. I know its on your end because I have a password management system that always remembers the correct one.

Regardless, I asked for a reset, got the email at my gmail account and proceeded to try to use the link in the email.

It just times out. I’ll attached a screen where its simply says:

This page isn’t working didn’t send any data.
It happens when its trying to go to this URL:
Deleted Link for security concerns.

The same error on both Chrome and Firefox.

Please let me know as soon as possible how to access my account. This completely prevents me from setting up my Farmbot, I have a crop to get planted!


The password reset function seem to work for me also as your links was working for me.
I made your link invisible to keep your account safe, since I can’t say if someone knows your email as well.

Please try again to reset your password. Your link seems weird, since there is no ssl (https) and port 443 inside your Link which is different in mine:

I also saw that there was an additional post on github, as I assume that it was not yours, so this is probably not caused on your side.

Still doesn’t work for me. (BUT I SOLVED IT) My detailed steps are:

  1. Go to:

  2. Click on “Forgot Password?”

  3. Enter my email address

  4. Click on “Reset Password”

  5. Go to my email, find the email from ""

  6. Click on the “here” in the " You can reset your password [here]
    which points to:

  7. It opens a new browser window and at the bottom it says:
    "Waiting for… "

  8. eventually it times out and the browser ends up at:


  • or at least I got around it.

As a work around I took the link resulting URL that timed out : “…” and I fixed it by making it look like this:
"… "
(for not techie types, if your trying to follow my tracks, the entire rest of the URL is included after the “…”, I didn’t touch that part)

1 Like

Glad that you got it working. :slight_smile:

This is probably something for @RickCarlino, maybe he can can take a look into that. I guess he is pretty busy with more important things right now, but maybe this is not a big deal to fix that.

Greetings! We are fairly certain we know the cause of this one. I will be working on a fix today- details to follow. Thanks to everyone who has provided debugging information! The fix that @TroyD has described here will work until the fix is deployed. Thanks, Troy.

Will the fix also fix the logging issue?
If so, I will hold off on re-flashing the FBOS…