connection issues

Thanks for your response. We are having the same issue as Tejas. We are in a standstill until we figure this out. Any advice or help would be appreciated. Thank you.

We have the same problem here. We downloaded the newest OS image. But it is still disconnected :frowning: I hope there will be a solution soon.

@TuinPi @pappalardoe @Tejas

Sorry to hear about the connectivity issues. Here are a few things to try:

  1. We have fixed some connectivity issues reported by users in FarmBot OS v. 3.1.0. It was released 2 days ago.
  2. We experienced a service outage this weekend while performing security updates. If you had an problems connecting on Saturday or Sunday, this may have been the cause.
  3. Some users have reported connectivity issues when they setup the bot for the first time that go away after doing a hard power reset.

One other thing to try:

In Chrome, press the ctrl, shift, and j keys at the same time. You should see something like this:

If you see any red error messages in this panel, please let me know. This may give an indication of problems.

I highly recommend re-flashing your SD card with the latest FBOS release (2 days ago) and re-running wifi configuration before debugging the problem again.

CC: @connor

Hi @RickCarlino,

This weekend I already flashed the sd card, did the configuration again and the wifi network isn’t visible after the configuration. So that’s a good thing.

But unfortunately I have a red error message in Chrome.

I hope this problem is fixed soon!

@TuinPi Thanks so much for sending that screen shot- it makes it much easier for us debug.

  1. The first error message that says set_user_env is happening because the bot is not connected properly. There is something happening on the Raspberry Pi side that is preventing the bot from talking to Chrome.
  2. The second message is unrelated to the main issue. Changing your webcam URL to a valid image feed/URL will make it go away.

Also, have you tried pulling the power cable out of the raspberry pi and plugging it back in after running configurator? We’ve been investigating an issue where bots freeze. The fix (for now) has been to pull the bots power, plug it back in, wait 5 minutes or so (so it can get back on WiFi) and then check the web app.

@tuinpi - Do you know what encryption type your WiFi router uses? Are you running any security software that would block network access from new devices? Currently, we only support WPA2, and it does look like the bot has indeed never been able to connect to wifi.

EDIT: WPA-2 Personal

Thank you for the support! I’ll let you if it worked.

When I looked at my browser now, I found another error. See the screenshot below.

@RickCarlino I’m having similar issues. My farmbot was connecting earlier today. However right now it is not. Here’s a screenshot of the errors I’m seeing.

@TuinPi Thanks for the update.

ERR_NETWORK_CHANGED is most likely an issue on your local network caused either by your router or by a windows configuration setting (apparently, this issue is common with Broadcom network devices). I found a few promising resources by searching “fix err_network_changed chrome” on Google, but can’t verify their usefulness, as I am not a windows user myself. Most of the fixes involve updating local DNS settings to use Google’s DNS servers.

@TuinPi @detchi - Can you please try running this test to see if your browser and network are configured to run websockets? Please let me know what the results are, as it will help determine if the issue is a local configuration or a server side issue. Thanks so much for your detailed responses.

:triangular_flag_on_post: IMPORTANT UPDATE :triangular_flag_on_post: THIS IS VERY OLD INFORMATION.

@detchi This looks like an issue with HTTPS certificates. It could be an issue on our end, or a local configuration issue on your local machine.

Could you please tell me your Chrome version? You can find it by opening chrome://help/ in a new tab and clicking the “ABOUT” link on the left side.

Also, when you visit NOTE ABOVE! THIS INFORMATION IS OLD :arrow_up: ) do you see a white page that says “not found” with a green lock on the address bar? If it is an issue with your local machine’s HTTPS setup, you might see a “back to safety” warning message.

Thanks again for all the information you’ve provided.

Hey @RickCarlino I’m able to connect with my farmbot again. Here’s my info in any event, Chrome 57.0.2987.133 and I am getting the page not found and HTTPS secure message at

However, I’m not able to get the bot to move at all at this point. It was successfully moving earlier this morning. I’ve rebooted the farmbot to no avail. I also can’t update the max speed on my hardware. It simply won’t save.

Any advice on how to troubleshoot all this?

1 Like


  • Were you able to pass the websocket test ( on your local machine?
  • What does the nav bar “sync button” look like? Is it green or yellow? Red indicates that there may still a networking issue at play.
  • Which version of FarmBot OS are you running? Version 3.1.1 was released 2 days ago with numerous stability fixes. Consider re-flashing and re-configurating if you have not done so already.
  • As for the issue with max speed, we are tracking a fix for that and will deploy a fix in the next week or so.


  • Looks like the websocket test failed (see attached)
  • I get yellow or green sync buttons.
  • I’m currently running 3.1.0. I’ll update that to 3.1.1 and see what happens.
  • Thanks for the update on max speed.

So what does it mean when the websocket test has failed but yet I can still connect to the farmbot?

And thanks for your help!

@detchi Can you try attaching the test results one more time? I’m not seeing anything on my end.

Sorry! Just updated my previous reply.

@RickCarlino I just updated farmbot os to 3.1.1. After doing so, I was able to connect the farmbot to my home network. However, it’s no longer connecting to the web app. I’m just seeing the red disconnected button.

Does this point back to a web socket issue? I’ve attached a screenshot of the console output.

@detchi I am still investigating the issue on my end.

Are you (or your router) using any Firewall or Antivirus software that restricts access to certain ports or content? It seems like the socket is getting closed unexpectedly.


I’m now getting a successful message from the websockets test (see attached). However, I’m still unable to connect to the farmbot.

I’ll double check my router and firewall to confirm i’m not blocking any ports or protocols. I don’t believe that I am.

Just found this post. Happy to see im not the only one!

I am having the same exact issues also.

I’ll provide screenshots of the needed info.

I believe my websockets are not working/accepting.

My firewall is 100% off at this moment. no change in websockets. :frowning:

I’ve flashed the OS 2 times so far with no progress on the configurator or even getting to see/connect to the FarmBots network (which leads me to assume it’s not launching the network config)

Hope some of the images i provided can help.