My.Farmbot.io connection issues


#21

@RickCarlino I just updated farmbot os to 3.1.1. After doing so, I was able to connect the farmbot to my home network. However, it’s no longer connecting to the web app. I’m just seeing the red disconnected button.

Does this point back to a web socket issue? I’ve attached a screenshot of the console output.


#22

@detchi I am still investigating the issue on my end.

Are you (or your router) using any Firewall or Antivirus software that restricts access to certain ports or content? It seems like the socket is getting closed unexpectedly.


#23

@RickCarlino

I’m now getting a successful message from the websockets test (see attached). However, I’m still unable to connect to the farmbot.

I’ll double check my router and firewall to confirm i’m not blocking any ports or protocols. I don’t believe that I am.


#24

Just found this post. Happy to see im not the only one!

I am having the same exact issues also.

I’ll provide screenshots of the needed info.

I believe my websockets are not working/accepting.

My firewall is 100% off at this moment. no change in websockets. :frowning:

I’ve flashed the OS 2 times so far with no progress on the configurator or even getting to see/connect to the FarmBots network (which leads me to assume it’s not launching the network config)

Hope some of the images i provided can help.

-Chris


#25

Oh almost forgot the error message im getting.


#26

@detchi @Cjaramillogrows Thanks for attaching test results. The test should say “Work for you!” rather than “Might work for you!”. There may still be a browser or network issue at play. Your browser was able to connect to an unencrypted WebSocket connection, but could not create a WebSocket connection via SSL.

I will continue looking into the issue.


#27

@Cjaramillogrows If configuration failed, you will not be able to connect to the bot.

Which version of Raspberry Pi are you running? If you purchased a kit from our website, you will have an RPi version 3. As of 14 April 2017, this image file is the latest FarmBot OS release for RPi v3. You can burn it to an SD Card using Etcher. Some users have accidentally burned a FarmBot OS version for different versions of the RPi, which leads to the bot being unable to boot.


#28

@RickCarlino

I discovered I am able to do a successful websocket test when using safari. I only get ‘might work’ results in chrome.

However, I’m still unable to connect to farmbot even in safari. I’ve attached my safari results.

I’ve also confirmed I don’t have a firewall or anti-virus running right now. Any ideas?


#29

@detchi

That’s good to hear! A few questions about the current setup:

  • Are there any red error messages in the Safari developer console like there were in Chrome?
  • Are you able to connect via mobile, using 3g or some network other than your current router? This can help rule out router issues. If the sync button (currently says “DISCONNECTED”) turns any color other than red, there is connectivity.
  • Can you still see a farmbot-**** wifi network on your network? That would be an indication that configuration failed (usually from a bad password).

#30

@RickCarlino
So I’m using the RPi v3. I’ll download the OS you’ve provided and install that onto my SD card, I will report results once I’ve done that.

So It’s safe to assume that the FarmBot wifi network hasn’t been established if I cannot see the farmbot-**** network name on my mobile device or my PC?

Also, I tried the web socket test on Microsoft Edge and all of my web sockets work (“Works for you!”)

my FarmBot just doesn’t seem to want to launch the wifi network.

EDIT:

So after installing the OS you provided the farmbot launched the network and i was able to configure.
once i tried to go to the https://my.farmbot.io/app/ and logged in it still says the Farmbot is disconnected, Yet the configuration said complete and prompted me to proceed to the next step which was loggin in to my.farmbot.io to check and see if the Bot is “online”


#31

I’m getting some XMLHttpRequest - network errors and some web socket errors.

These are the results I’m able to provide as of my current standing.

i\I know the f|Farmbot did launch the wifi network and I know that the config went through properly. After such, I become lost with what the possible issue may be=.


#32

Hi @RickCarlino,

We solved the problem here. The network was wrong like you suggested. After changing the network to a WPA2-P key the problems were solved!


#33

@Cjaramillogrows A couple of things:

  • Have you tried running the app in Chrome? We don’t test against MS Edge at the moment and have seen compatibility issues on some parts of the site with Edge. We hope to support Edge in future releases, but right now we only test against Chrome and Firefox.
  • After running WiFi configuration, does the farmbot-**** wifi network go away? If the WiFi network disappears, but comes back a few minutes later, it means that FarmBot failed to login (and needs you to try again).

Please let me know if that’s the case and we can keep investigating from there.


#34

@RickCarlino

I have tried it in both MS edge and Chrome. With no change.

The network does stay visible and up after I go through the config process but from the end of the Web App it says the Farmbot is offline and disconnected.


#35

@RickCarlino and @Cjaramillogrows

I’ve been having a number of similar issues and might know what the issue is. After installing 3.1.2 my farmbot again went offline.

I ran the configuration and it appeared to complete successfully. However after that, the local farmbot network was still visible and farmbot was not connecting. I’ve noticed that sometimes it appears that configuration has been successful when in fact it has failed. So I ran the configurator a few more times until the local farmbot network was no longer visible. I was then able to successfully connect to farmbot.

I had to run it several times. I’d give that a shot.


#36

@Cjaramillogrows If the Wifi stays up after set up, that would indicate an authentication issue (configuration was not successful). A few more things to try:

  • Double check the WiFi password. I’m assuming you don’t have any issues with your email/password if you were able to open the app in Chrome and Edge, but generally speaking, the bot will try to log in three times. If there is a network failure after 3 attempts, the bot will reset and wait to be re-configured.
  • Try hooking the bot up to ethernet instead of WiFi and then log into the app after configuration. If the bot shows up as “online” over ethernet, it could indicate an issue with WiFi credentials or router configs. If your bot is already outside, you can hookup “just” the RPi for testing purposes- you don’t need to unhook anything else.

It sounds like your browser and web app are working fine, but the bot has never been able to get online. Please let me know if either of these help.


#37

Ok got it,

I’ll try to run the set up a few time to see if i can get the wifi network to go away after the config goes through.

thanks!!


#38

I will report back whenI I’ve tried these suggestions.

much thanks for the help from both of your guys! I really appreciate it.


#39

Just to throw in a thought: I had trouble connecting to my wifi from the farmbot if I typed in the name of my network (although it looked like it was successful) and could only get it to connect if I used the drop-down to choose my wifi name. Once I did that connection was great.


#40

interesting.

I actually cannot find my farmbot when i hit the “Scan” Button.

hmm.