My.Farmbot.io connection issues


#41

When you connect to the farmbot-xxxx and run the configurator, it wants you to connect to your own wifi network. You shouldn’t see the farmbot wifi from there I don’t believe. When you hit the Scan button does your wireless SSID show up in the list? Can you post a screenshot of the scan?

If you’re standing next to your 'bot, can you connect to your wifi from a laptop or your phone? If not you might need a wireless repeater.


#42

When i try to scan my farmbot does not show up.

here is a screen shot

I can connect to the wireless network from my router/wifi without any problems.

The farmbot on the other hand seems to be having issues.

I’ve tried repeatedly connecting to the network it creates with sessions of on off in between.

EDIT: you cannot see the other 3 wireless networks up at the bottom of the scroll but i can assure you that the farmbot-1c6c is not there.


#43

Hey @Cjaramillogrows

what you see in this list, are all Wifi SSIDs in your place. You need to choose a Wifi network, that farmbot can connect to. You cannot see the farmbot wifi because you don’t need it there.

Simply take a wifi in that list that you have access to, insert the password in the field below and also your Email/Password of your my.farmbot.io account. Now click Submit Configuration and wait for the Page to show you more instructions.

For additional Information take a look at Wifi Configurator. :slight_smile:


#44

I’m so embarrassed lol!

@Ascend @RickCarlino @bonanzajellydog @detchi

thank you all so much for the help.
I’ve got the Farmbot up and running!!

I also realized that because I’m at a school I couldn’t use their network to connect the Farmbot because
they have a 2 stage authentication login and the configurator doesn’t allow for multi-stage authentication.

the next step for me is to update the Farmbot and confirm I can get movement from all motors and components.

again, thank you all so much! Ill still be active in this chat for some future questions I may have.

Farmbot community, you are awesome!! :slight_smile: :heart_exclamation:


#45

@RickCarlino.

after updating the farmbotOS, I noticed that I cannot get it to launch the wifi network now. After I just finally got it connected and working. I could move her around a bit but eventually, I would get a
"did not receive error" and noticed my farmbot had disconnected.

After updating the OS the farmbot can’t launch its own wifi network. I can’t find it on my wifi search and I also noticed that before this issue when I was connected and the farmbot was working I saw 1 red right (solid) and 1 green light ( blinking on the RPi3 board, and the RAMPS board would have 1 green light down at the bottom left corner.

Now the only light that’s on is the 1 solid red light on the RPi3

i’ll continue to troubleshoot with what I can.

It was so exciting to see it move!!


#46

My link seems to keep dropping.

I just started with 3.1.3

any suggestions?

best
al


#47

After updating to 3.1.3, was the Farmbot able to launch the network and were you successful in configuring the network but unable to see your Farmbot online in the my.farmbot.io/app/?

I’m stuck on step one of all that, where my Farmbot won’t launch the network. :frowning:


#48

@Cjaramillogrows I will forward this issue to @connor, the main developer of FarmBot OS for when he gets in tomorrow morning. 3.1.3 is a very fresh release. Will keep you posted. And glad to hear all the WiFi stuff is sorted out.


#49

Much thanks for everything, I appreciate the help.

  • Chris

#50

hello just catching up here, hope i can help.

So with a fesh burn of an sdcard do you get the farmbot-xxxx wifi access point?

If so when you configure network, What is the type of network security you are using? right now farmbot only supports wpa2-personal but work is being done so check back soon for that.

if you have good network, and good web app credentials, it will not show the farmbot-xxxx access point any more, and you should be able to connect.

A solid red light indicates possibly either the wrong image was flashed to the sdcard, or possibly a lack of power to the device. (farmbot’s raspberry pi3 requires about 3 amps @ 5 volts.)


#51

Hello,

Thank you for helping me!

So I do not get the farmbot-xxxx wifi access point with a fresh burn of 3.1.2.
in the process of trying to solve this issue, I burned a 3.1.2 OS version onto my SD card and it successfully launched the wifi access point. ( I had tried 3.1.2 and 3.1.3 multiple times with multiple burns with zero results not sure why this random 3.1.2 burn was successful).

I now am connected to my Farmbot and I am getting some movement, kinda. Sometimes I can get it to move left on the X axis and then when I try to get it to go back on the X axis to the right I get this small click sound that comes from whichever motor is needed to move the bot and I get little to no movement or only a quarter of the previous movement direction.

“TREEGROWTH’S ARDUINO SAYS: STOPPED” I was getting some movement earlier and then this response can into the logs after a minute delay and zero input responses.

I do have some confusion and questions about the Arduino firmware.
I have not figured out how to install the Arduino firmware, are these problems directly related to the fact that I don’t have the movement firmware installed on the Arduino.

-chris


#52

So the firmware is now coupled to the OS and is not user changeable (unless you are a developer and you are testing firmwares). It will get installed on boot/update if there was an update.

You problem sounds like you may have encoders enabled. Encoders are still under development by our Hardware developer @Tim. If you temporarily disable encoders, does you bot more?


#53

So the encoders are disabled

So just to confirm my understanding. When I installed the farmbot OS (3.1.2) it also installed the Arduino drivers?

Another question, when I hit the update button on the device tab these are the responses i get.


#54

So just to confirm my understanding. When I installed the farmbot OS (3.1.2) it also installed the Arduino drivers?

This is true yes.

Another question, when I hit the update button on the device tab these are the responses i get.

Github actually broke our release system. You will need to update to 3.1.3 I believe.
Now You said that 3.1.3 did not work that is because you have downloaded the wrong image. (the one you have is for raspberry pi 1) The names of the images are all sort of close. Sorry about that but we made a table to download the correct one here


#55

Ahh got it, ok cool! I have a game plan for now again.

My last question is about the movement commands & direction.

So you have the left, up, right and down arrow keys on the controls tab in addition to the vertical up and down Z axis arrows.

when I hit the down arrow for the Z axis it moves up and vice-versa for the up key.
the other keys inputs seem off also, Left arrow key moves the farmbot on the along the X axis, the and the other arrow keys seem to input the wrong command. Also, I can only get so much moment out of the bot.


#56

So if your motors are moving the wrong direction from what you think they should be; you can just flip the connector the other way around.

so if the cable is plugged in like this and right makes the motor turn left.
[y o w b]

you can just change it to look like:
[b w o y]
and it should turn the other direction.

As for the other problem, it sounds like you may have x and y plugged into the wrong spot or something.

@Gabriel may be able to help you there.


#57

Roger, got it.

Hey, thanks for the help Connor!

If i have any other questions ill shoot you or Gabriel a message.

-Chris


#58

Yes, if you disable the encoder, the bot moves with step count on the motor. That’s no issue at all for normal moving. However, home/calibration needs either an encoder or end stop. Still working on the encoders.


#59

Hello @Tim

I do have my encoders disabled.
I also have allowed negatives all on and end-stops all off.
In addition, i also changed the moment speed from 800 to 500 with better results.

I’ve gotten a much better range of moment out of my Farmbot but I noticed that whenever I try and move the full length from left to right on the Y axis, it begins moving and once it gets closer to the end of the Y axis the motors seize up and won’t move. If I give it a little nudge/push the motor usually picks back up and the bot begins moving.

I’ve checked the tension of the cable system I’ve looked at the motors and everything seems pretty fine.

Also, side note, my farmbot will receive a command to move the Z axis up or down but sometimes the farmbot will receive the move command and then tell me movement was incomplete with zero physical response from the bot.


#60

If it just picks up after pushing, it sounds more like the motor drivers can’t provide enough current. Turning the screw on the driver a bit should fix that.

What do you mean with telling the movement was incomplete? Is that in terminal or on the web page?