Network steering causes issues for Raspberry Pi


#1

Today we figured out that the Raspberry by can work on a Dual band modem (2.4-5). However Band steering needs to be turned of completely. This feature in your modem pushes all traffic to the least congested band > 5Ghz. The Raspberry doesn’t support that.
We are in a corporate network here and cannot change these settings.
We will try to use a Dual-band usb stick.

To be continued.


#2

Raspberry Pi 3 does not support 5ghz, but Raspberry Pi 3 B+ does. Unfortunately we don’t ship the new B+ with Farmbot kits.

As for a usb stick, the driver will not be enabled. If you tell us the model of the usb stick, we can consider adding it if it is a relatively common device.


#3

I found a good priced, good reviewed and quite often used USB dongle from TP-Link:

  • TP-LINK Archer T2U WiFi stick 433 Mbit/s

You mentioned it will not work, does that mean we will -if you can integrate it- be able to use it in the next update of the FarmBot OS?


#4

I’d be dropping in a Raspberry Pi 3 B+ board instead of going to a USB WiFi device.
You may need to bring the WiFi router closer to the bot to get good 5GHz signal strength.


#5

I am working together with Sietse on the same Farmbot. Today we replaced the Raspberry Pi 3 by a 3B+ model. Unfortunately that did not solve our connection problems. Farmbot will still not connect to the wifi network. Signal strength for both 2.4 Ghz and 5 Ghz is very good at our location.
Does it require any additional settings/configurations to get 5 Ghz working on a Raspberry Pi 3B+ for Farmbot?


#6

@RobB {caveat: I’m not a FarmBot team member, just a developer type, playing with FarmBot OS on my own RPi3B+ boards with no hardware connected . . but I have bought a V1.4 Farmduino board to play with in the near future}.

Assuming you succeeded using the initial “factory reset” Configurator AP web site at 192.168.24.1 …
What actually happened after that ? Did you get another “factory reset” after some time ?

(If there is a problem which causes the FarmBot OS to “factory reset” itself then there’s usually a
nice detailed error report on the initial page (at 192.168.24.1) when you connect to the FarmBot Configurator AP next time.)


#7

No special configuration needed. Just choose a 5Ghz WiFi when configurating. Maybe you will need to make changes in your router settings to split 2.4Ghz and 5Ghz into two seperated networks.