No connection between arduino and raspberry pi


#1

Hello everyone!
The farbot was working well. Suddenly from yesterday, the webapp shows that the connection between the raspberry pi and the arduino is disconnected and when I try to move the farmbot using the controls tab, I get the message that the relative movement failed. Any idea what I can do to trouble shoot the problem?


#2

Hey @nithu
check your wire between the Raspberry Pi and the Arduino. It may also help to change the USB port on the Raspberry where its plugged in, but you need to restart the Bot afterwards.


#3

Hi,
I tried changing the USB port on the raspberry pi but there was no change in the status. I also checked the wire by using the wire to connect the arduino to a computer, the arduino switches on. This indicates that wire seems to work fine. Is there any other possible reason that this could be happening.


#4

Maybe your Arduino Firmware was not properly flashed. This could be caused by an interrupted OS update sequence. In this case you could try to reflash your SD card and proceed the steps in the configurator, so the arduino gets flashed properly.


#5

I tried re flashing the SD card but the same problem still persists.


#6

Which Farmbot version are you using? Can you file a diagnostic dump by clicking “Diagnostic Reports” and then “RECORD DIAGNOSTIC”. This will send a report to us and we can help diagnose.


#7

Hi, Sorry for the really late reply. I am using the v1.2 version. And I will send the diagnostic report. Thanks so much for your help.


#8

I filed the diagnostic dump as suggested. It gave me a report number. Do i need to provide the number here?


#9

Is it possible that something in the arduino has fried? Even when I connect the arduino to the computer, it gets powered up but the computer does not recognize it.


#10

Some LEDs on the arduino board should light up when connected to your computer. If thats not the case at all, try to unplug the RAMPS board (additional board on top of the arduino) and connect the arduino again with your computer. Also check the pins, maybe there is a short circuit because of bent pins.

I guess it would be helpful for connor. This number is only used to match the report ticket to you and does not contain any personal information.


#11

None of the pins are bent. Those look fine.

When the arduino is connected to the computer, the “ON” led lights up but the computer does not recognize the arduino board. I am not able to even install the drivers just to check if the board is working fine.

The report number is k0j84.


#12

I figured out a solution to the problem. The arduino board was faulty. The issue was resolved when I replaced the arduino board with a new one. Thank you so much for your help.