Number of points must be greater than 0 for all three axes

I have successfully built Farmbot 1.7 Genisis. The build was easy enough and everything works - but I cannot make it do anything beyond move, pickup tools and run all of the peripherals.

For example I wanted to use a sequence to ‘Photo Grid’ but all I get in the error “Number of points must be greater than 0 for all three axes”. I have tried other sequences with the same result. I have also tried to create Group of Points and set up a variable as ‘externally defined’ but all I get is the same result.

Searches do not yield any results.

The build instructions were good but after the build the documentation to make it work seems to tail off. It would be nice if there were instructions to walk a person through planting two plants in a sequence and setting up care for them. I feel our of my depth right now that I purchases something I do not know how to use.

Any thoughts from anyone?


Hi @mvillion have you run Camera Calibration successfully ?


@mvillion I checked the farmbot_os code and garden_size may be returning invalid values . . Did FIND HOME execute correctly on all axes ?
I haven’t seen the startup documentation that you’re using . . . You might need to set your garden lengths manually once.
That’s the SET LENGTH buttons on the Axes configuration menu.


Camera calibration = Yes.

You nailed it. I went into settings, axes and there were 0,0,0 for bed length.
I ran the full X,Y and Z test which populated the numbers and it fixed the issue.

Thank you

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.