Offset move command turns into custom coords move after sync

Seems like a bug:

  • Create new sequence.
  • Add Move command, location Seed Bin, Z offset 100.
  • Add Move command, location Offset from current position, disable X/Y axes, Z offset -50.
  • Save the sequence, wait for sync.
  • Second move command updates to Custom coordinates.

Expected behaviour would be to keep the Offset from current position because if the first move command location ever changes, the second move command’s absolute coordinates don’t make sense anymore. They need to stay relative to the first move command.

Before sync:

After sync:

Is the actual behaviour of the second MOVE correct ?
( despite the move block showing Custom Coordinates )

Two other questions :slight_smile:

  • The first MOVE statement has SAFE Z checked, the second one unchecked. Does that make a difference ?
  • Why Disable axis for X and Y versus leaving OFFSET both 0 ?

It is. Seems like a UI bug.

Toggling safe Z doesn’t resolve the bug for me.

Why disable axis? It makes more sense semantically (to me) but it’s a matter of personal preference I guess.

I will let Gabriel know about this on Monday, @mdingena. I will let you know what we find out.

@mdingena We have added this bug to the backlog. Thanks for the heads up. :+1:

1 Like