Photo grid sequence not running

So after calibrating my new camera (had to get a replacement), I wanted to run the photo grid sequence and while it was running it before re-calibration… Now when I hit run, it shows “Starting Photo Grid” and one second later it shows “Completed Photo Grid”

I was having wifi issues but I solved that bit and am getting almost 80-85 signal consistently, so I’m doubting it’s a network issue.

Thanks for your help!!

Hi @alexgalicea

  • Can you snap single photos ?
  • What camera devices has FBOS found since last reboot ?

e.g. ( I have no camera wired up a.t.m. )

@jsimmonds Yes I’m able to snap single photos. And I just have the standard camera that came with the kit (Express 1.1) it’s showing as Connected.

Just to clarify this, are you saying that Photo Grid worked with the new (replacement) camera prior to recalibration of it ?

Are you able to connect to the Raspberry Pi serial console ? or are you able to rebuild FBOS with SSH support ?

@jsimmonds Yes. Exactly.

How would I go about doing that?

@alexgalicea Thanks for clearing that question up.

Without any log details from FBOS when it attempts to run Photo Grid sequence it’s trial and error.
You might try FBOS cold boot followed by another Camera calibration process ?

@roryaronson and FarmBot developers should have access to your bot’s telemetry and logs and since that FEATURED SEQUENCE was developed and published by FarmBot Inc. it may be best to ask for help there.

Connecting to FBOS Console ?
Easy if you’re a software-hardware-savvy type but not so much if you’re not. There are a few posts in this forum that might help, but way too much and off-topic to lay it out here :slight_smile:

I will try a cold boot and a re-calibration. @roryaronson what would be the process for you or the team to verify telemetry?

Thanks all of you for your help (Marc too!)

@jsimmonds I attempted the cold boot followed by another calibration and now I cannot get a new calibration to go through.

Even with the current calibration it’s still failing the sequence after the cold boot and reflashing.

Next I will try the alternative calibration method…

1 Like

@alexgalicea were you able to re-calibrate your camera? Calibration is necessary after any change to the camera hardware. Even simply loosening and re-tightening the camera mounts can alter the angle of the camera slightly, which requires recalibration.

Once calibrated, can you share a screenshot or copy/paste of any error logs you are seeing when trying to run the Photo Grid sequence?

I was able to calibrate it. I can take photos manually but when I try to run the photo grid sequence, it instantly shows Completed photo grid. No errors showing at all. @roryaronson

Have you entered in an AXIS LENGTH value for the X and Y axes? The Photo Grid sequence calculates the locations FarmBot needs to travel to based on the size of your garden bed.

And just to make sure, you are running the latest version of FarmBot OS (v15.3.4), correct?

Correct on both

I have been unable to reproduce your issue so far with any of my devices. Have you by chance made any modifications (intentional or accidental) to the Photo Grid Lua code? Something you could try would be deleting the sequence from your account and making a fresh import of the original.

If that doesn’t help out, can you fill out the Provide feedback form in the app here? That will create a support token that I automatically receive and can use on my end to login to your web app account so that I can check on a few other settings to see if I can get to the bottom of this.

1 Like

I will attempt that once more, I will send the ticket in if all else fails.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.