Photo of whole bed, plants at Z=0, foto at Z=-200


I successffully created my first sequence to take a picture of the whole bed.

All my plants are planted at Z=0, which is weird since Z=0 is home, and that is way up in the air. Anyways, when I take pictures of the whole bed, the camer is too high, so I wanted the camera to move to -200 and take all the pictures from there.

The sequence I created allows me to take pictures of whole group of plants, using the VARIABLE EXTERNAYLLY DEFINED, which works great. FB takes the coordinates from the plan position and moves there, however Z=0 for the plant, hence it is impossible for me to keep the camera at Z-200 even if I set it at the beginning in the OVERRIDE

Any ideas?

@JollyJoker I will take a look at this issue later today. The MOVE block / OVERRIDE features are very new, so it’s possible there are some unforseen edge cases.

Have you tried setting the Z-axis offset to -200 instead of using an override?

Also as a side note, we are currently working on a feature that will allow users to move the device to “SOIL HEIGHT” and “SAFE HEIGHT” (user definable).

Thanks for the reply, yes I tried offset as well. What it does, it goes to Z=-200 (-400 in the picture because it was already at -200) at X=0 and Y=0 and then moves to the first plant of the first group which is at 100,100,0

@JollyJoker I am having trouble reproducing the issue you mention:


Was there anything different about the way you ran your MOVE block?

Hi There Rick. It must be something else that prevents the override from working. Z always goes back to 0

Found my mistake: the override has to be on the single step created for the subsequent sequence that uses the command EXECUTE SEQUENCE. Now it works.