Plant-detection Farmware crashing


#1

I have a set of sequences which detect plants over the full garden. Most of the time the farmware to detect plants works, but sometimes it crashes (and thus locks the robot).

Here is a log of such an occurence:

I have not found a way to see what the exact error was.


#2

@roryaronson or anyone from FarmBot, some help please! My scheduled daily scan of the garden for plants has not succeeded even one single time, the bot always gets e-locked, defeating the whole concept of automatic gardening and rendering the bot useless. I’m at a loss here.


I’d say that about 1 in 100 calls to the plant detection fails like this, at random positions. Since the bot has to take any analyze 166 photos to fully scan my garden it always breaks somewhere before completing the garden.


#3

When manually resuming I can get the full scan to complete, but even then there are some of the photos missing, without specific reason. The missing photos seem to correlate with “Got idle while executing a command.” log entries (warning).


#4

Another day another error… I guess this time it just crashed the whole RPi?


#5

Just the connection crashed. If the Raspberry would be restarted or something similar, the coordinates would have been set to 0.

  • How are you connected with the Internet? WiFi or Ethernet?
  • Log levels are set to 3 for all kinds (max)?
  • Does it change anything if you turn AutoSync on?
  • Are you using a huge sequence or running a farmware to run this operation?

#6

Log Levels: Yes, they are at max.

AutoSync: Have not tried that, will do. Edit: Tried, does not change anything. Aborted in the middle of the harden.

Huge sequence/farmware: This is a recursive sequence set which travels over the garden in a snake-like pattern (home, y min…max, x++, y max…min, x++, y min…max, …) and runs the plant detection farmware at every spot over the garden. So yes, the initiated sequence is long-running, but the farmware is not.
One other thing I noticed is that disk usage raises by about 5%-10% each time the sequence is initiated and I already had to factory reset because of a full disk .

The connection is currently WiFi (on a Ubiquity AP with disabled legacy 2.4GHz support to avoid ripple protection issues). Connection quality is good and stable: