Problem with installing FarmBot software

Everything seems fine until I get to:

cd farmbot-raspberry-pi-controller
gem install bundler
bundle install
rake db:setup

I get errors:

bash: gem: command not found
bash: bundle: command not found
bash: rake: command not found

Is there a step I missed? Thanks in advance!

This is probably because the code is written in Ruby and with gem they probably mean Ruby Gems.

See this answer: http://stackoverflow.com/a/9492083/2190172

Much appreciated!

I just had to run:
sudo apt-get install rubygems
cd farmbot-raspberry-pi-controller
sudo gem install bundler

…and that seemed successful.

But then when I try bundle install I get all kinds of errors :confused:

Now I get the error:

Gem:InstallError: something requires Ruby version >= 1.9.3.

But I know I updated Ruby, so do you know how to fix this?

Good day

I added the following commands and it seems to have worked.
I log in as root on the system via Putty.
I followed the instructions to the letter and in step one I used “sudo apt-get remove ruby* --purge” and this obviously uninstalled the current version of Ruby.
I am not a Linux expert though.

Aditional Steps:
sudo apt-get install ruby-dev
sudo apt-get install ruby-full

\curl -sSL https://get.rvm.io | bash -s stable
$ rvm install 2.3.0
$ rvm --default use 2.3.0

Kind regards,
Riaan

That’s just what I needed, much appreciated! Now all I need to do is build the thing.

1 Like

You are welcome, let me know if it worked for you.

It seemed to work :+1:

1 Like

Happy to have helped.

Hello makers, i’m new in raspberry pi system and i’ve a little problem XD

When i do ‘bundle install’ i’ve got this error:
'could not locate Gemfile’
however i’m in the farmbot-raspberry-pi-controller directory

i’ve try to remove ruby (as you advise in this topic) before reinstall ruby 2.3 and it’s doesn’t work

good afternoon :slight_smile:

Hi @fansa336,

We just recently completely switched the way the controller and raspberry pi stuff is installed and updated. In short, we now have a repository named “FarmBot OS” which, as it sounds, is a complete operating system that includes the controller and a little app that allows you to connect the pi to your home wifi network and your farmbot web app account really easily. Just follow the install instructions here: https://github.com/FarmBot/farmbot_os#first-time-installation

This system also features over-the-air updates so you can install the latest controller and firmware by clicking a button in the web app’s device tab :slight_smile:

1 Like

Hello roryaronson,

big thanks for your help, after 4 hours i’ve succes to connect to my farmbot

but i had more difficults to create the sd card because when i put into the raspberry pi i attempt to see a desktop on my screen and when you configure one time your pi with the WiFi, it’s impossible to change the informations and the single solution was format sd card and reload the os

so an thank you again for your time and your help :grin:

@roryaronson so I followed the easy instructions and it’s still not working out for me. After writing the image to the SD card and and puting it in the pi, I get a black screen with lines of code, and the last line says:
random: nonblocking pool is not initialized
any idea what went wrong? I’m using version 2.0.3 if that makes a difference.

hello Randman77,
did you have connect to your pi with your phone to configurate it ?

@fansa336 I haven’t gotten that far, I’m still trying to install the OS

You shouldn’t need to have a screen, keyboard, or mouse plugged into the Pi to install the OS. Simply put the SD card into the pi, plug the pi in to power, and then use your phone or laptop to connect to the farmbot configurator to complete setup. You do not need to go through a traditional OS install process.

Oh, and we are working on a way to “factory reset” the device from the web app. But for now, if it does not connect to wifi or a web app account successfully then it will simply restart the wifi configurator app so you can edit the settings.

Hallo everyone,

first I would like to thank the coding team for sharing Farmbot OS to the community. I am using it since version 2.0.0 was released. I managed to config and control the farmbot, but my connection always died after a few commands.

When I try to config with the farmbotconfig WLAN, It seems there is no SSID found, since there are always 3 “test SSIDs” shown (test_ssid, meeeep). Multiple wireless connections are in range and stable, but not shown in config page.

Is anybody else struggling with connecting?

Also recently I always had to boot the bot a second time to get the ‘farmbotconfig’ SSID shown. But seems like it got fixed, since 2.0.3 it’s not an issue for me anymore.

Cheers