Problems with X-Axis movement

I am trying to “tune” my parameters for quiet mode on my Farmbot Express 14.3.1.
Y and Z motions are working fairly well although the Z axis on finding home does not end up on the stop (a centimeter or a bit more below).

Currently though I am having trouble with the X-motion which starts in jerks (a couple of start/stops and then fails movement. The following screen shot of the logs shows this. The most recent log entires are after trying an all plants watering sequence; but doesn’t even get to the first location without failing. (BTW: It would be helpful in the logs to add an info log entry indicating the name of the sequence that is starting.)

I had tried tuning some of the motors parameters and had just finished successfully manually moving in 100 mm steps also showing in the toward the bottom of the log screen shot.
I am guessing that it might be the combination of x and y motions that is, indirectly perhaps, causing the failure.
Here are my current motor settings for [REDACTED]

Any help on parameter recommendations would be appreciated.

Hi @dlmcshan a few things:

  • In the future, please do not post personal information such as your email address. You can find your device ID, which is not considered sensitive information. on the connectivity panel (click the green dot on the top navigation bar).
  • Tracking changes: As a note to anyone who might be reading this thread: it is possible to see which motor tuning values differ from factory defaults. Any value with a yellow border around it indicates a non-default value. This is useful for resetting values that have been changed erroneously.
  • X motor jerkiness: Consider setting your ACCELERATE FOR (MM) value back to 12 mm/s. This is an advanced setting that very few users need to change. Although some users do like to tune this value, I have never needed to change it on any devices I own. You may wish to set the Z values back to their defaults, also (or not, if you find that they operate fine with the values you have entered).
  • Viewing logs for the currently executed sequence: The web app supports this. Visit the logs page and enable the options shown below to activate this feature:


Please let me know how the motors behave after resetting the X value to default and we can go from there.

Device ID: 11526
Version: v14.3.1
Model: Express v1.0
Firmware: v6.6.2 Farmduino (Express v1.0)

I tried resetting my hardware parameters using the "Reset" button under the settings section for Parameter Management.   Now, for some reason, many settings are outlined with yellow and some unchanged (like the Accelerate field). So, the "Reset" set to something other than the defaults. Is there a convenient way to reset individual files to their default?

I downloaded the parameters from my other bot and uploaded them to this bot. And set the accelerate to the default value of 12. However, when I started my watering sequence again I got the same failure as before.
The following is probably a different problem:
I next tried just moving the X-axis to 1000mm and then did a Find Home. When the x-axis went to seek home, it went there hit the stop, backed up a bit and then rammed it again and stayed there while grinding its wheels endlessly until I hit the Stop button and did a Set Home to reset the way negative position number it had achieved. I guess in Quiet mode it must never reach the max load (60) but not sure why it spends so much time trying the Grace period is 100 (it certainly cranked longer than 100 steps). Here is the position versus time graph:

Paragraph below was all on one line in the message above. Here is what it

Thanks for the update, @dlmcshan I will take a look now.

Yes, you can find the default value for a parameter by clicking the (?) icon next to the name of the parameter:


@dlmcshan OK, I took a look at your account. Everything looks like it has a good value now and you are on the right track: lowering the MAX LOAD a bit for the problematic axis will allow the bot to recognize the stall at the home position. There is documentation here: Stall Detection | FarmBot Software Documentation

This value is different for every setup, so it will require some experimentation. The documentation offers a more complete explanation. I am happy to answer any questions you have if you still have issues.

I just ordered some parts to add limit switches to my bots. I hope that will eliminate my homing issues.
In the meantime I will turn down the Max Load. However, the manual control’s load graphics hardly register anything when it is “Finding Home”. I thought that might be because of the Quiet Mode. If I turn that off it finds home without the same issue.
Thanks, again.


One small disclaimer I will add about limit switches (especially for anyone who is reading this thread): FarmBot, Inc has never sold a commercial kit that supports limit switches. Back when FarmBot was a small “garage project” and we were not a fully formed company selling kits, we had some prototypes that used limit switches. We kept that code around in the firmware but since we don’t actually sell limit switches (and never have) we are unable to provide in depth support to users of limit switches.

Ideally, I hope we can solve your issue via conventional means. If you are unable to solve this by tuning the stall detection values, we may need to hop on a phone call to dive deeper into the issue.

Also, just to confirm:

You currently are able to use your device, but you are not able to use QUIET MODE, correct?

No, I am able to use my Farm Bot Express in the Quiet Mode if I avoid “Finding Home”. But there are still some occasional problems with movements failing. I will still work on some parameter tuning tomorrow.

Also, I understand that the hardware limit switch solution is not supported but will still give it a try just to see if I can make it work. At the very least I will try and use the 2-wire shielded wire to replace the power feed to my vacuum motor which is STILL causing interference which locks the system despite replacing the motor and the controller board for one of my bots.


OK, please let me know how parameter tuning goes tomorrow. We may need to hop on a call if you do not make any progress there, since “FIND HOME” is a very critical step for the devices operation.

Please let us know how progress on this goes. I am unsure how many devices in the wild are using limit switches successfully.

This was an oversight on our part in the design of the 1.5 board. It passed through our review process because unfortunately the issue only happens to a small subset of devices. After v1.6 is released, we can get you a shielded replacement cable free of charge (the issue is fixed in v1.6 but we have not finished production of the new units).

Please let me know of any updates. If you still are not making progress we can arrange to discuss this matter over a video call via private message.

So, I have worked on my bots and have finally found a parameter that seems to help running in Quiet Mode. I am using All of the default parameter values with the exception that I have set the Motor Minimum Velocity for X & Y axis to “0”. I had tried to use the Accelerate parameter and was puzzled why it didn’t seem to change the ramp up speed.
I suspect the ram-up speed is (or computed to be) faster in the Quiet Mode.

To troubleshoot this, I put together a small sequence to move to (0,0,0), wait (1000ms), move to (1000,1000,0), wait (1000ms), move back to (0,0,0).
Before setting the minimum velocity, sometimes it succeed but it seemed like if I repeated the sequence t too quickly it would start failing. I was thinking that maybe the motor was getting to warm.
I tried not leaving the power on the X&Y motors which did seem to help.

But so far, just setting the Minimum Velocity to zero seems to be working for both of my bots and I was able to complete my all plant watering sequence on both.
I will exercise them a bit more over the next couple of days to see if the fix sticks.
I didn’t modify the z-axis minimum velocity but will try the change my sequence to exercise the Z-motion also and see if things still work.

Glad it is at least working- I have passed this along to the team to get their thoughts. Please let me know if you hit any other issues.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.