Raspberry Pi Camera cannot take photo


#1

Hi,
I changed to the RaspberryPi camera, but I am not sure whether the connection is correct or not? The left side is the Raspberry Pi camera with the real-time clock, and the right side is just the slot for connecting to the RaspberryPi.
image

But the system result is weird, it shows the calibration error (no idea about error conclusion, what does the “2 required” means?). But when pressed “take the photo”, the system is shown “completed without error”.
After we took several photos for server times, the album still shows nothing…
Kindly review and please help.
image


#2

I assume you have already selected the “Raspberry Pi” camera type in the Device widget and are using the web app at my.farm.bot. When you press the Take Photo button, are there any other logs that appear?

I would recommend trying to take normal photos before trying to calibrate the camera, but once you get the camera working see the camera calibration documentation for more details about the calibration error.


#3

Hi Gabriel,

Yes, I have selected the “Raspberry Pi” camera type in the Device widget and are using the web app at my.farm.bot. After pressing the Take Photo button, it told us that the camera takes the photo successfully. But we waiting for an hour, there is nothing in the album…

We have tried to take the photo before camera calibration but nothing happens, after calibrating still nothing happens.


#4

Do you see trying to upload and successfully uploaded log messages? Taking a photo should generate about five log messages on the Logs page with all filters removed.

Some other things you may have already tried:

  • Select USB Camera and try Take Photo again to make sure USB camera photos can be uploaded.
  • Plug the Raspberry Pi camera in directly without the extension and adapters to make sure it is working correctly.
  • If the USB camera works but the Raspberry Pi camera does not (and you have prior experience with Raspberry Pis), you could plug the Raspberry Pi camera into a Pi running Raspbian to try to get it working.

#5

Hi Gabriel,

Below are the status when we took the photo. BTW, it did not show upload successfully.

plug the Raspberry Pi camera into a Pi running Raspbian? I try to use Putty to SSH Farmbot Raspberry Pi but it shows that “Conection refused”, So just wondering how to access the Raspbian in the Farmbot RaspberryPi.
Appreciate your response :slight_smile:


#6

It looks like the Raspberry Pi camera was not detected. Have you tried plugging the camera in directly without the extension and adapters? If you want to try it with Raspbian, you would need to download and install it as you would on a normal Raspberry Pi (keyboard, monitor, etc.), which is why prior experience with that is recommended.


#7

Hi Gariel,

Thanks for your prompt reply, I will try it :slight_smile:


#8

Hi Gabriel,

I have test the RaspberryPi camera in my raspberryPi, it works well and can take the photo!
But when I insert it into the farmbot RaspberryPi, it always shows error…

What’s the meaning of “at least 2 required”? I cannot find the related information in your farmbot document


#9

The two objects required refers to the objects needed for camera calibration. As described in the documentation, when calibrating the camera both calibration objects need to be visible in the camera’s view (which should also be clear of background objects).

However, you can still use the camera to take photos without calibration by pressing the Take Photo button.

I assume you are plugging in FarmBot after connecting the camera, and it looks like the ribbon cable is correctly oriented. Have you tried switching Raspberry Pis?


#10

Hi Gabriel,

Thank you for all your assistance, now it can work