Raspberry Pi to Farmduino Connectivity failure

Hello, I’m trying to diagnose my farmbot connectivity issue.

When I try to send a command using the farmbot web app, the bot starts to move and connectivity between raspberry pi and farmduino immediately drops. Often, it will automatically reboot and re-flash the firmware when this happens.

Network connection from what I can tell isn’t dropping. Any help is appreciated!

I have tried:

  • flashing the latest farmbot OS (multiple times)
  • rebooting
  • moving the wifi router

I don’t believe this is a wifi issue because i’m still able to take photos and view them while raspberry pi/farmduino show as disconnected.

Seems like a power connection issue if it drops when the bot moves. Start at the main power supply and check all your connections up to the devices and also inspect the cables for worn through or pinched insulation.

That’s a good thought. I’ll try that out and see what happens.

Appreciate the response!

Still no good.
I tried alternate outlets, cords, and secured all cables.

I find it happens most often when I am trying to find “home” for the x-axis. I have tried lowering the speed, voltage, etc. but still get the disconnected message above. I reverted back to default settings, same issue.

My logs also don’t show any voltage drops/issues.

I’m beginning to wonder if it’s the farmduino board or raspberry pi itself having issues.
It’s new out of the box, so I would hope not, but I’m running out of ideas.

@10ndavis sorry to hear you are having troubles. Can you look at the logs page and set the filters all to their MAX setting and let me know if you see any error messages like the ones highlighted in the image below?

If you see logs like this we will need to send you a replacement Farmduino Express electronics board, free of charge of course. You can email support@farm.bot with a link to this forum post and your shipping address and we’ll get you a replacement board sent out this week.

If you do not see logs like above, we’ll need to do more intensive troubleshooting. In this case, please submit a troubleshooting request by using the Provide feedback form in the app. This will allow us to login to your account remotely to perform further diagnostics.

1 Like

@roryaronson Thanks for the reply!

I see some error logs, but not exactly what is above.

Here are a few of them (they are all nearly identical):

Failed to execute command: {{{:badmatch, nil}, [{FarmbotOS.Firmware.GCodeDecoder, :“-parameterize/1-fun-1-”, 2, [file: ‘lib/firmware/gcode_decoder.ex’, line: 130]}, {Enum, :“-map/2-lists^map/1-0-”, 2, [file: ‘lib/enum.ex’, line: 1593]}, {Enum, :“-map/2-lists^map/1-0-”, 2, [file: ‘lib/enum.ex’, line: 1593]}, {FarmbotOS.Firmware.GCodeDecoder, :parameterize, 1, [file: ‘lib/firmware/gcode_decoder.ex’, line: 129]}, {FarmbotOS.Firmware.GCodeDecoder, :process, 1, [file: ‘lib/firmware/gcode_decoder.ex’, line: 100]}, {Enum, :“-map/2-lists^map/1-0-”, 2, [file: ‘lib/enum.ex’, line: 1593]}, {FarmbotOS.Firmware.UARTCore, :handle_info, 2, [file: ‘lib/firmware/uart_core.ex’, line: 172]}, {:gen_server, :try_dispatch, 4, [file: ‘gen_server.erl’, line: 695]}]}, {GenServer, :call, [FarmbotOS.Firmware.UARTCore, {:start_job, %FarmbotOS.Firmware.GCode{command: :F82, echo: nil, params: [], string: “F82”}}, 600000]}}

Failed to execute command: {{%RuntimeError{message: “CORRUPT ECHO! Expected echo <<71, 48, 48, 32, 88, 49, 48, 48, 48, 46, 48, 48, 32, 89, 48, 46, 48, 48, 32, 90, 48, 46, 48, 48, 32, 65, 57, 48, 48, 46, 48, 48, 32, 66, 57, 48, 48, 46, 48, 48, 32, 67, 49, 53, 48, 48, 46, 48, 48, 32, …>> to equal “G00 X1000.00 Y0.00 Z0.00 A900.00 B900.00 C1500.00 Q121””}, [{FarmbotOS.Firmware.TxBuffer, :do_process_echo, 2, [file: ‘lib/firmware/tx_buffer.ex’, line: 130, error_info: %{module: Exception}]}, {FarmbotOS.Firmware.InboundSideEffects, :reduce, 2, [file: ‘lib/firmware/inbound_side_effects.ex’, line: 127]}, {Enum, :“-reduce/3-lists^foldl/2-0-”, 3, [file: ‘lib/enum.ex’, line: 2396]}, {FarmbotOS.Firmware.InboundSideEffects, :process, 2, [file: ‘lib/firmware/inbound_side_effects.ex’, line: 46]}, {FarmbotOS.Firmware.UARTCore, :handle_info, 2, [file: ‘lib/firmware/uart_core.ex’, line: 175]}, {:gen_server, :try_dispatch, 4, [file: ‘gen_server.erl’, line: 695]}, {:gen_server, :handle_msg, 6, [file: ‘gen_server.erl’, line: 771]}, {:proc_lib, :init_p_do_apply, 3, [file: ‘proc_lib.erl’, line: 226]}]}, {GenServer, :call, [FarmbotOS.Firmware.UARTCore, {:start_job, %FarmbotOS.Firmware.GCode{command: :G00, echo: nil, params: [X: 1.0e3, Y: 0.0, Z: 0.0, A: 900.0, B: 900.0, C: 1.5e3], string: “G00 X1000.00 Y0.00 Z0.00 A900.00 B900.00 C1500.00”}}, 600000]}}

Failed to execute command: {{%RuntimeError{message: “Failed to look up unexpected firmware response code: nil”}, [{FarmbotOS.Firmware.GCodeDecoder, :map_get, 3, [file: ‘lib/firmware/gcode_decoder.ex’, line: 146, error_info: %{module: Exception}]}, {FarmbotOS.Firmware.GCodeDecoder, :process, 1, [file: ‘lib/firmware/gcode_decoder.ex’, line: 100]}, {Enum, :“-map/2-lists^map/1-0-”, 2, [file: ‘lib/enum.ex’, line: 1593]}, {FarmbotOS.Firmware.UARTCore, :handle_info, 2, [file: ‘lib/firmware/uart_core.ex’, line: 172]}, {:gen_server, :try_dispatch, 4, [file: ‘gen_server.erl’, line: 695]}, {:gen_server, :handle_msg, 6, [file: ‘gen_server.erl’, line: 771]}, {:proc_lib, :init_p_do_apply, 3, [file: ‘proc_lib.erl’, line: 226]}]}, {GenServer, :call, [FarmbotOS.Firmware.UARTCore, {:start_job, %FarmbotOS.Firmware.GCode{command: :F11, echo: nil, params: [], string: “F11”}}, 600000]}}

Edit: take that back, it just printed this error:

UART timeout: <<82, 57, 57, 32, 115, 116, 101, 112, 32, 99, 111, 117, 110, 116, 58, 32, 55, 50, 48, 48, 13, 225>>

Thank you for inspecting the logs. It looks like we will need to send you a replacement electronics board. I will create an order for you now which will ship out on Friday.


Thanks so much!

@roryaronson , really admire that you got involved personally to help a user solve a problem. A great example of a customer service leadership.


I am having the same issue as 10ndavis, however my logs look entirely different. I’m showing the firmware getting flashed often and reboots every couple of minutes. I have not tried to reflash anything since setup so I’m not sure why it is doing it. I’ve attached a screenshot of my logs, but am unable to upload a 2nd pic of the connectivity page.

Here is a screen grab of my realtime connectivity. The CPU temp looks a little high and it’s not a hot day out today.

Decided to re-flash the Pi and start over. This time I got an error stating “UNABLE TO SELECT FARMDUINO”. The Pi connected to the Farmduino eventually and it’s back to it’s connect/disconnect cycle.

I also have a recent order that generates logs similar to this. It is a great relief know I’m not alone! I have tried re-flashing the SD card and starting from scratch. I submitted a help request thru the configurator form today. Much appreciate any advice!

I submitted a help request through the configurator as well, but haven’t heard anything yet. Have you received any help yet? I’m wondering if I have bad hardware. Thanks!

I emailed them at contact@farm.bot and got a prompt response … new board is en route. Good luck!

That’s great news! I just sent an email as well. Hopefully we’ll both get this solved soon! Thanks for the update.

Hi all,

I am facing exactly the same problem as you guys just today. The firmware updates seems successful but i still get connection error to the farmduino.

Have dropped contact and also support at farmbot for their reply. Glad i am not the only one.

PS: One funny thing i found was that i flashed the latest os update on 32gb card and only error i had was the farmduino connectiin. I thought it needs to be exactly the 8gb card as it stated that large volume cards will give errors. But when i swapped with a flashed 8gb reformatting the one that came with farmbot and reset everything, not only did i have farmduino connection error but now also message broker error :face_exhaling:

Swapping back to the 32gb card removes the msg broker error


Please email us at:


We will resolve your issue.

Hi Marc,

I have already dropped you an email under the email

Thanks for the quick reply. Much appreciated !