Re-enable console

Hi! I’m trying to set up my farmbot, but after a single setup I haven’t been able to get the pi to connect to the app. I get the config screen, set it up correctly, the wifi turns off… and nothing happens. It never connects to the web app or turns the wifi back on. I’ve tried a different pi, different sd cards, reverting to 4.0 and 3.1.6, nothing seems to work.

So, I’m trying to just get to the logs to see what its doing, but I can’t get any HDMI output. I’ve tried ctrl+c while its running like the FAQ suggested, but that didn’t do anything. How can I get a command line interface?

We will update the FarmBotOS FAQ soon to reflect these changes and provide some options. In the meantime, have you checked the troubleshooting tips in the post quoted above? It’s possible that it did connect to the web app, but communication to the device is blocked by a firewall. You can try logging in to the app through a different network to test it (after closing all other browser sessions), such as a mobile phone on data. You can also check if the device shows up in your router (if you have access to the connected devices list) to make sure FarmBot successfully connected to your WiFi after configuration.

Thanks! I should have mentioned, I’m using an ethernet cable, not wifi (the wifi network I want to use needs both username and password, which I’m not sure how to configure). That being said, this was the approximate sequence of events:

  1. I tested the raspberry pi unconnected to an arduino using the ethernet cable. It installed fine, connected to the app, I turned it off and went away happy.

  2. Since then, I have been unable to connect in any way. I’m working at a university so I talked to the IT people, and they confirmed that
    a) The firewall shouldn’t be stopping any outgoing requests
    b) They can’t so much as ping the pi when its running FarmOS
    c) When the same pi runs Raspbian, it can surf the web just fine, so it’s not a hardware or network problem.

It seems like after a successful config (I also tried giving it garbage login information, but it restarts the wifi correctly when my password is wrong, so it’s definitely getting some connection to the server) the pi just drops off the network. I don’t have a USB to TTL cable, but I can try to get one. I also saw earlier in the thread that the pi would write a log.txt to any attached thumbdrive. Is that still a feature? Even just getting that much might be helpful.

Have you confirmed that the Pi is in fact running? One “fragile” thing about Pi’s is that sometimes the flash card self ejects when your handling it and that will of course keep it from booting. Just something to check.

The Pi3 has status LED’s on the board.

I’m pretty sure it is. Red LED is on solidly, green flashing irregularly but consistently.

Here’s the links to the Pi status LED’s and Pi troubleshooting guides from the Pi foundation for future reference. Red indicates that the power supply is good, but the green may be a problem. You need to look up the green flash pattern in the second line below:

And a troubleshooting guide in magpie (free download) here: