Scheduled Sequences not running

Hi, I have a few water all plants sequences in my calendar already scheduled and they do not seem to be running. When I run the sequence manually through the web app, the sequence is executed perfectly. Any suggestions?

@PTMU When these issues occur, it is best to enable “E-STOP ON MOVEMENT ERROR” so that you get an error email if the bot stalls when you are away (which is often the case with failed movements).

I have enabled E-STOP ON MOVEMENT ERROR as well as verbose logging (so that you can see more log messages that may contain useful information).

Please let me know if the problem happens again tomorrow and I can investigate the matter further.

Hi Rick,

same issue here. Recently my Farmbot stopped performing scheduled watering: I set “E-stop on movement error” to ON but this morning the routine was again not performed.
Any hint?
Thanks

Silvio

Taking a look now @Sizen . Just to confirm I understand the situation- are you saying that the FarmEvent did not run, but you did not get an E-STOP email?

Which of these did not run? “Abbevera meloni”, “Piante piantate”, “Abbevera semenzaio”

Hi Rick,

that’s correct, none of the FarmEvents scheduled run and I don’t get any email, not even in the junk mail.
But all of them used to be performed correctly, up to last week.

Regards

Silvio

@Sizen Unfortunately I am not seeing too much on my end- there are no errors logged on the device related to sequence execution. The difficult part of investigating FarmEvent problems is that there can be a number of things that make a sequence fail. Unless you are near the device at the time of execution, it is hard to know the exact cause. It could be something simple or overlooked, or it could be an internal to FBOS.

In the past, we have seen a problem related to local data on the SD card causing problems. This is not always the case, but if that is what is happening, the problem can be fixed by performing a hard reset (soft reset will not clear corrupt data).

Please let me know if a hard reset helps.

Additionally, I have set your log filtering settings to MAX temporarily until we can determine the source of the problem.

Hi Rick,

the hard reset solved the issue.
Thanks for the assistance.

Silvio

That’s good to hear @Sizen . I am still investigating the matter and will let you know if we find anything on our end. Thanks and have a great weekend.