Sequence crash + self factory reset

What would cause this output in the middle of testing a sequence? I found that it also performed a factory reset. The farmbot it renamed and broadcasting it’s own wireless network now
See my attachments for the logs


Notice the last inmate and at what position the gantry is at. Definitely not -1,-1,-1.

Also, is there a way to reduce the speed only for “move to home on boot” just like in the sequences where I can run it at a % of the maximum speed?
The stepper driver got the x motor seem to be overheating on my genesis xl 1.4 it can’t make it the 5800mm track on one run even at 20% speed.

Might help https://software.farm.bot/docs/connectivity-codes you may want to post your motor and encoder config from the device page.

Thanks, i didn’t think to do that. By the time I found it was broadcasting the farmbot-###aaa wireless network…i knew it wasn’t connected to the message broker anymore because it was broadcasting as if it was never setup. The passphrase, SSID, and firewall configurations have not changed for my local wireless network.

It looks like something happened to my onboard OS

So you’re up and running again?

Hi Tom,

I found it was broadcasting the farmbot-###aaa wireless network…i knew it wasn’t connected to the message broker anymore because it was broadcasting as if it was never setup.

By default, a FarmBot installation will factory reset itself if WiFi is lost for more than a few minutes. This makes it easy to move a device to a new location or change the password on your WiFi router. Some users with intermittent WiFi connectivity (or sporadic WiFi interference) may notice unintended factory resets if this setting is left enabled.

You can disable this feature by opening the “Power and Reset” panel on the device settings page. A screenshot of the setting is provided below:

With regards to your motor issues, I will take a look at your firmware settings today and report back any findings. Thank you for your patience.

1 Like

FIND HOME ON BOOT uses the HOMING SPEED setting, so reducing that value will reduce the speed during that process (as well as during other find home and calibrate commands).

1 Like

@MaryslandFB Did disabling factory reset help with your issue? Please let me know if not and I can continue with troubleshooting.