Sequences acting weird on v3.0.8

Hi guys thanks for the help these days, I’m almost done with my farmbot build but I’ve been having trouble with my sequences after updating to v3.0.8 where it seems to be executing commands like absolute movement without waiting for the previous command to end, this is really weird because version v3.0.6 actually worked really well in that regard but I had to update since I was encountering lots of “UH OH” errors when trying to sync. Also in version v3.0.8 (release) when I try to save a new farm event Farmbot just disconnect and need to reboot. I just dont know what to do, is this a problem with the version, the web app or my device?
Has someone encountered these problems? I just want to get my farm going!

I share your anxieties. I’ve been really excited and impressed with the new Farmbot hardware updates, but the spring equinox was yesterday, in an already early spring. My Farmbot won’t even calibrate yet. What OS version did you calibrate yours with? It’s my understanding that they are rolling out an updated version sans the bugs soon (a few days). In the mean time, I’m starting a few crops indoors then transplanting the starts once the Farmbot is up and running so i don’t miss spring planting. I live on the boarder of growing zone 7 and 8. I wont get to see the seeder in action for Kale, but considering planting starts instead of seeds could help relieve your anxiety. If you live in growing zones 5 minus , you should still have some time for the spring planting of most crops. Here is a link to help you know if this years’ early spring will affect your area. (assuming that you live in the United States) It’s acting more like mid April where I live.

Being on the cutting edge of this groundbreaking technology may cause us to flex our creative muscle if you aren’t a programer (like myself). I know that Farmbot is designed to care for your garden from seed throughout the life of the plant. You may run into unforeseen issues if you decide to plant transplants. If you decide to go that route, please post your successes and failures. I will do the same. We could be a very valuable resource for each other.

Hello @jmLafarga.
Are you only having this problem on movement commands such as “move relative” and “move absolute”? if so a temporary fix would be to add “wait” commands in between them. Im investigating this problem right now!

as for the “uh oh” syncing issues sorry about that, i believe that should be fixed soon on the web app side. It seems to be related to Heroku

I only had problems with chaining sequences together via “Execute”. First Sequence was running but when it was done and started the other sequences it only stuttered while sending the moving commands really fast.
Adding a few millisecs between every call worked great so far.

1 Like

Hi again, I have only tested movement commands so far and using wait seems to work but only if the position is reached before the waiting time is over. But now I get UH OH! errors with any version so I guess thats a server issue maybe? what causes this UH OH error?

Anyway should I wait for a new update on the web app or can we try to set up a local server? Thanks for the help!

So that bit “UH OH” has to do with Farm Events. I just changed the message to be more meaningful which will be available in the next release.

Its hard to know exactly what caused the issue without seeing the Farm Event that was trying to be worked on, but it is likely a problem with both the OS and the web app as Farm Events are in active development.