Sol sensor and Tool verification not working

Hey Guys,

I’m having trouble with my soil sensor and tool verification. I don’t get a response out of both of them.

I’ve reviewed this post to see if I missed anything but I’ve had zero luck.

I crimped ring terminals to the UTM tool head end of the cable to establish better more secure connections and also have adjusted the screws that make contact with the tool head as suggested in the post I linked but nothing :sob:

How can I test to see if the pins on the Arduino board are working? I’ve tried using a voltage tester on pin A/1 and created a peripheral so that I can turn the pin on and off in an attempt to get current to run through to make sure the pin is activating but that hasn’t provided any results either.

are there any other suggestions anyone can make?

I’ve exhausted all options I’ve tried to come up with so I thought id make a post and see if there are any suggestions.


I assume you have followed the documentation so that you have the UTM connected to RAMPS (A: 5V, B: GND, C: D63, D: D59). You can connect your voltage tester across A and B and make sure you read 5V.

After testing to make sure you are reading 5V on A, to test the input pins use the READ SENSOR button in the Controls page Sensors widget. Without anything mounted to the UTM, press READ SENSOR for each sensor. You should see readings at the right end of the bar. You can then connect B to C at the UTM and press READ SENSOR again for pin 63. You can do the same for pin 59 by connecting B to D. You should now see sensor readings near the left end of the gauge/bar.

You can follow the same procedure at the RAMPS board and at the UTM to make sure both are working and connected properly.

Right on Gabriel.



A post was merged into an existing topic: Farmduino vs RAMPS

UTM is preassembled, so how do you check ramps?,