Solenoid valve doesn't open

Hi all,

I’m new here on the forum. :wave:

First of all thanks for making such a nice piece of equipment. At the community, we all love the idea of a robot doing the most repetitive garden work.

We are a few issues with the Farmbot Express XL and one of them is the solenoid valve that doesn’t seem to open.
I have checked with a voltmeter if its being powered up and it seems to be the case.
When I try a different 24v dc adapter on the valve it opens straight away.

vacuum pump and lights seem to work fine.

@Catfarm Have you tried reversing polarity on the valve? Please let us know and if you have, I can take a deeper look.

I’m guessing that there is a diode or something that only allows current to flow through the solenoid in one direction, incorporated in the solenoid that stops back EMF from the water solenoid’s collapsing magnetic field from being fed back into the system and potentially causing damage. This is why @RickCarlino has asked you to check for polarity reversal.
Just thought I’d explain, or else you might wonder why, when a solenoid is just a coil of wire, polarity would even matter.

1 Like

Doesnt seem to work in both ways…

@Catfarm We’ve seen this help some customers in the past, but it appears that there is some other issue at play. I have forwarded your issue to the hardware folks for further review. They will reply by Monday (California time) if not sooner. Thanks for your patience.

1 Like

Whilst you are waiting @Catfarm, you could check to see what is being sent to the water solenoid if anything. Given that you’ve established that the water solenoid works with an external power supply, you could check with a multimeter in order to find out a few things:
1/ Is there any power at all being sent to the water solenoid?
2/ If there is power, what voltage and how long for
3/ The polarity of the voltage (if any)

Using this information you can continue to diagnose the problem. I’m sure that the more info you can provide to people on this forum, the better and more “on target” the help will be.
Good luck

1 Like

i fixed it!

Marc from Farmbot suggested to me that it could be the cable.

Checking the cable for continuity I found out that the mass was not connected properly inside of the socket.

IMAGE 2020-04-06 12:39:07|375x500