Stepper motors issues

My farmbot is fully assembled. It boots up fine and has been configured, and the latest arduino code has been installed. The vacuum pump works, the water nozzle works. But when I try to move the bot in any directions, I hear the stepper motors give one click then nothing happens. The robot is centered in all axes so its not hitting hard stops. It just wont move. Any suggestions?

I’ve been encountering this same problem, randomly. Usually I solve it by power cycling the Pi. I’ve encountered this problem after changing certain settings, too. Sometimes if I change the “Max Speed” in the Device page from 1500 to 500 it works better. I have to change these speeds to prevent a problem where the z and y stepper motors seize halfway through a movement. At slower speeds, they execute fine. Perhaps this is a related problem.

Can you take a screenshot of your hardware widget on the device page?

Same here. If you allow the ‘relative motion’ to move more than 100 mm nominal distance, like for example allowing the 1000 mm movement then it tries to accelerate to a higher speed and the motors seize up violently (well sort of) and stop about 200-300 mm into the move. I’m hoping that the encoder code (when it gets here) will fix that issue.

1 Like

Some troubleshooting suggestions:

  • Reduce Max Speed value to around 800 or less
  • Disable encoders and end-stops
  • Try moving both directions

Hi Gabriel,
Here is the snapshot you requested.
Thanks in advance for your help!
Flavio

1 Like

It’s sort of working now. I’m having it boot up with the bot in dead center of my work space. But seems to not want to go negative, even though I have enabled “allow negatives”.

Ok all seems ok when I startup robot with Z at top-most position, X in back-most pos, and Y in right-most position. It seems this is the only possible coordinate system I can use.
Flavio