Stepper Motors not responding on X-axis

Hi y’all.

I’ve owned my Genesis XL 1.6 for a while now and I’ve managed to self-troubleshoot based on a lot of what’s in this forum, so thank you to the community. This latest issue is mind-boggling though.

I had a sticky 2nd X-axis motor - it was perpetually falling out of sync a few steps, leading to the gantry twisting and a total X-axis stall.

Did some troubleshooting, swapped cables between the X-axis, swapped the motors around, and have verified that all motors are still indeed working.

However, now after troubleshooting when connected to the X-axis wiring, when sending a command to move, BOTH x-axis motors refuse to turn over - they just vibrate in place.

I can connect either of these motors to the Y-axis wiring and send a command there, it turns over smoothly.

This tells me I’ve either got a software/firmware problem or a wiring problem, but only on the X-axis. The odd thing was that X1 worked fine before I started troubleshooting, and now both X1 and X2 don’t work.

What are some thoughts and ideas? I’ve tried reflashing the Farmduino from the interface, but that hasn’t seem to work


I’m just now setting up my Genesis-1.5. I had a weird X-axis problem that ‘suddenly’ showed up after a period of normal operation, and it turned out that the ‘length’ parameter of the X-axis was set to an absurdly low number. This must have happened when I did a ‘find length’ operation that didn’t complete successfully. The symptoms in my case was that the x-axis refused to move, or if it did move, would always go in the -x direction, and wouldn’t stop until it hit the hard stop. Punching in a reasonable value for the length fixed it.


Thanks - I’ve double-checked that and it’s not the problem.

Basically after a whole bunch of troubleshooting, it seems the X-motor ports are fried. When I route the cables from the Y-motor ports, the motors respond and move.

I’m looking at getting a replacement Farmduino.

The reason for the vibrating motors is usually that one motor coil is not energized because of a broken wire or a defective driver.

So the Y-Motor with its Y-cable is also not running on the X1 and X2 ports at all?

Yup - basically whatever signal is coming off the x-ports aren’t correct. If I connect the Y-cable and thus Y-motor to X1/X2 output - the motor behaves that same way - that in-place vibration without any turning of the belt.

I’ve even wiped the Farmduino with the Arduino IDE to then reflash with the Farmduino firmware. Problem still persists.

Right, thats not a software issue I guess. Maybe damaged connector on the board? You could try to take the board out and check the soldering points on the downside. Also check for bent/misaligned pins inside the connector.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.