Strange crash - Flashing unlock LED and dead e-stop button

I just had a strange crash. After pressing a couple of buttons, the FB behaved strange.

The e-stop button LED was on. The Unlock button LED was slowly flashing and the FB ignored my button pressrequests to e-stop. I had to pull the power cable on it to get it to stop.

Not had that one before.

I also caused a new crash. After the power up (after pulling the power cable from above) I pressed button 4 which is my ‘water all’ sequence button. The FB tried to execute the sequence (running into the end stops) even though it had not fully reset from the previous power reboot. I have a sequence set to execute after a reboot to find home and perform a few house keeping activities such as pulling tools away after finding home. It appears you can force the FB to run a different sequence before the reboot sequence if you press the button at the right time. I assumed that the reboot sequence was protected and the reboot sequence would execute firs, before running anything else.

I know I have raised many issues and questions in the FB forum over the last few months, and I am sure some people may be a little fed up with me, especially as I keep finding software issues. A large part of my professional work is cyber security, including finding ways to test and break systems, so I naturally look for strengths and weaknesses in any system. You only end up with a robust system through the uncovering of these and the subsequence addressing of these issues. Reliability and repeatability are the most important things. You need to be able to rely on a system to do exactly what you expect when you expect it. else it is not a system.

@mvillion Yes, you’ve revealed known behaviour in the FarmbotOS.

Have you also tried ‘injecting’ a Sequence execution while another Sequence (or Farm Event) is running ? (use the RPC API) :slight_smile:

The Sequence On Boot feature was coded so that the configured ‘On Boot’ Sequence was given to the CeleryScript Scheduler to be scheduled rather than executed now . . perhaps naively. It wasn’t expected that sequences attached to buttons would intervene so soon after a restart.

You’ve probably noticed that the On Boot Sequence is deferred until the Farmduino MCU is fully up and ‘healthy’.

Maybe raise a GitHub Issue in farmbot_os repo if you feel this behaviour warrants change.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.