Uploading photos to self-hosted local server

Hi guys! I am also having a problem with the Webcam but this is on our local installation here is the error: Please Let me know if there is a folder that needs permissions or is this something that the Farmbot is trying to email the image to another server?

We had the same issue with he camera error and just resent the camera setup to be USB camera and it worked. Our issue now is the image will not upload from the /tmp/images directory which I assume is on the Farmbot Hardware controller.

Is there any way to have the Farmbot take a photo and just email it as an attachment to a specified email thru sequences?

Which service are you using for image hosting? Emailing photos is not currently implemented (you would need to set up an email service anyway).

I would recommend looking through your config/application.yml file and making sure you have deleted the lines with settings that are recommended to "delete".

Setting these up are some of the reasons why using the public server at my.farm.bot is much easier than provisioning your own (for those that have the option).

@kc6esn Hi, I got the same problem, and I noticed the image controller uploads photos to Google storage , which is not available in where I live, besides, accessing https://my.farmbot.io is very slow here. Do you think if it’s possible to disable the uploading and save photos directly on the local server?

Yes, you can save photos directly to the local server by following the directions in config/application.yml.

So the lines that said to delete for local storage in the application.yml file reference sendgrid and Google cloud service. All lines are commented out. So what path is the farmbot trying to send the image ?
Is a path to be specified? And about the /tmp/images folder, Is this folder on the farmbot hardware or on the local server?

Just a note Gabriel, the whole idea of using a local server is to gain speed and reliability. The access to the farmbot.io site is slow and very intermittent when controlling the farmbot. This fact isn’t Farmbot.io’s fault. By using a local installed server, the farmbot is fast and solid and reliable to control.
We are just working out the bugs and posting possible improvements so the whole framework is solid.

Hi Gabriel . I am following up on the error I get in the log.

I also have my yml file

All lines commented out. Where is the /tmp/images file located? On the server or the Farmbot Gantry?

We’ve made some changes in the latest release, and uploading images should be working.
You can run the following command to update your local server (code):

rails api:update

Where do the pictures get safed to? There is no /tmp/images on my local server. There is only tmp in the farmbot-web-app folder, but in this there is no images folder. Will they be safed to the Raspi SD card? That would be not very practical I guess…

They don’t show up in the web-app as well, but there is a success message in the log which says it was uploaded to /tmp/images…

I tried to run the api update, but it seems to fail.

After a restart, because of the server error I occasionally get, the pictures are in the web app at least. Still there is no folder pictures in tmp on the server

@derletztename It looks like you have some uncommited local changes. Try this:

git add -A
git commit -am 'Upgrade'
rails api:update

To answer your question about where the images are stored: you will find them in public/system/images/attachments. They will be deeply nested in a folder structure that is optimized for our image manipulation library.

An example path might look like this:


It would probably be easier to right click and "save image as..." from your browser into a different folder.

Thank you for the infos. I will try to figure out an optimal way for me to work with a lot of fotos.

Regarding the uncommited changes. I don’t understand that. I don’t use an own version of the webapp in Github and I don’t refer to anything different in the application.yml or something. How could I have uncommitted changes? Maybe the changes in the application.yml themselves?
If I comit my “changes” would I mess with your Github entry?
Excuse my lack of knowledge regarding git and stuff

So I tried your tip with the git upgrade and now everything seems broken :(:cry:

@derletztename Try git stash followed by rails api:update instead if you have not made any changes to the app. That should undo any incidental changes that may have occurred.

If you’re curious to learn more, I would recommend looking for a good tutorial on the Git Version Control System.

Everytime I try to update the server there is some error with bundle. This time it was the nokogiri installation.
I “solved” it by just overwrite all existing WebApp files and kind of start over.
Does the update mechanism work better for others?