What is tool verification

What does the tool verification do? It appears that mine is not working. See screencast.

@jorrflv

Did you review this documentation?

I have, and then I have now read the new documentation and whenever i have a tool mounted it always reads “no tool” all the wiring and everything has been triple checked… What am i missing?

@Marc any other thought on this… tool sensor and soil sensor still not working properly.

It is possible that when your tools get mounted, the screw heads on top of the tool are not making electrical contact with the UTM’s pogo pins. You might try adding a small washer in between the screw head and the plastic tool to help bridge that gap better and ensure the screw head contacts and depresses the pogo pin when the tool is mounted.

It is also possible the pogo pins were depressed but didn’t spring back out like they should. Perhaps due to debris. You might try pressing them in quite a bit and releasing by hand, and adding small bit of lubricant of some sort to ensure they pop back out all the way after a tool is mounted.

I don’t know if the following can help you, but the default “Mount Tool” sequence that came pre-loaded with my new Genesis XL 1.5 showed “Tool verification -> is -> 1”.

Changing that from 1 to 0 solved my tool verification issues.

My mount tool sequence now shows the following:

Ditto, looked like default is reversed