X-axis 2nd motor not moving

Hi, I assembled my FarmBot v1.4 just over a month ago, and it has been working great. However, a few days ago, the 2nd motor on the x-axis suddenly stopped moving, so whenever I move the FarmBot, the X1 motor is trying to drag the whole thing and stuttering (please see video). When I manually push the gantry, the right gantry column feels quite stuck and has a clicking noise as it moves along. The FarmBot is updated to ver.6.4.11.

I have already tried the following:

  1. Swapping the X1 and X2 drivers for the motors on Farmduino - the problem moves to the other motor. If I plug in the Y motor or the Z motor cables into the X2 socket, Y and Z becomes stuck and can’t move.

  2. I’ve tried the different hardware settings such as turning on and off the Always power motors, invert motors, enabling and disabling the 2nd X motor, turning on and off the invert 2nd X motor, as well turning on and off the encoders. Below is a screen shot. Nothing works.

  3. Even with the FarmBot powered off, as soon as I unplug the X2 motor cable from Farmduino, the gantry moves smoothly when I push or pull manually. As soon as I plug it in, it becomes stuck again.

This problem started suddenly overnight, literally, so I have no idea what’s wrong. There was nothing wrong with the tension of the belt or the track itself.

The log sometimes records: Movement to (9.8, 904.2, 193.2) failed. Sometimes the movement is recorded as successful, but in reality it dragged the right gantry column very forcefully to the set coordinates.

Please help…

Sounds like something may have gone wrong with the X2 driver. Can you try swapping the X2 and AUX drivers?


Yes, I forgot to mention that I did try plugging the X2 motor cable into the AUX previously, and I tried it again just now to double check: when plugged into the AUX, the X2 motor doesn’t move on command (it’s dragged by the X1 gantry column), but when I push or pull manually, the gantry moves smoothly without being stuck, stuttering or clicking.

My AUX driver is usually unused.

Just something else I tried, if I unplug the X1 motor cable and leave the X2 in the X2 driver and tell FarmBot to move somewhere, there is no response from X2 motor at all. Listening carefully to the motor, there is only a faint “click” sound when I press E-stop.

Throughout all these tests, the log always records that the FarmBot is moving to whatever coordinates, even though the X2 motor is not turning at all.

Can you try unplugging the X2 and AUX stepper drivers (photo) from the board and switching them? Sorry, I thought that was what you meant before when you mentioned swapping the drivers.

It works!

After swapping the X2 and the AUX drivers, and plugging in the X2 it works as normal.

Sorry, my fault, I am an electronics dummy, all I knew was how to swap cables…

Let me know how I can get replacement drivers.

Thank you so much for the help!

Glad it’s working! You can email support@farm.bot for replacement parts or browse shop.farm.bot to pick up extras.

Thanks again!