X-Axis Encoder not Working


#1

I’ve successfully been able to get my Y and Z axis encoders working but my x axis encoder is unresponsive. I’ve tried both inverting the x axis encoder and not doing so. I’ve also double checked the wiring several times. It looks correct. Anyone have any idea what’s going on? Or suggestions on how to troubleshoot?


#2

Hi @detchi

Ok so this is going to be kinda redundant but gotta make sure so i know what troubleshooting you have done!

  1. You tired inverting encorders? - yes
  2. You have the thin black wire as the ground wire and not the thick black wire as the ground?
  3. Have you tried to reduce the max speed down to 450?
  4. when you the Farmbot a move command does is move to the destination without any issue? 100% continuous movement?

#3

here is a resource posting with some simple troubleshooting tips also.


#4

Hey @Cjaramillogrows

  1. Yep, I tried inverting encoders.
  2. Yes, I made sure to use the thin black wire.
  3. Yes, I’ve tried a max speed of 450.
  4. Yes, I get 100% continuous movement. The motors are working well. Only the x axis encoder is not reporting any data.

And I saw the FAQ. I’ve checked all the encoder wiring several times.


#5

Alright, I only see two things that need to be checked to point out if the encoder is faulty.

-make sure the encoder outputs are connected to the pins for X-axis, not for X1. X1-encoder is not being used yet.
-exchange the connection of X-encoder and Y-encoder. This way you can see that the encoder is not working itself (I think it’s obvious already).

If you still can’t find anything that made it work, use X1-encoder and let us know about your results.


#6

I too was going to suggest that at this point it seems the encoder itself is faulty.

@detchi It seems like thats the most probably cause.


#7

@Ascend @Cjaramillogrows

I tried swapping the x encoder cables with the y encoder cable. That still didn’t work. That led me to believe that the x encoder & motor were bad so I swapped x motors. That didn’t work either.

What’s the best way to check the cable and ramp shield? Those are my next guess.


#8

So you swapped the cable on motor and ramps side, or connected the Y-encoder from Y-motor at the pins for X-encoder?

Means that you swapped X- and X1 motors with their encoders and connected the connectors at the pins needed for X-axis? I think it would be very unlikely that both encoders and cables are broken.

My guess is that the signal won’t arrive at the digital pins on the arduino mega board. I would check if the pin headers on the arduino board are okay and if the Ramps shield is pressed on correctly.

Maybe @Gabriel knows a way how to troubleshooot the ramps/arduino, maybe softwarewise?