X axis keeps getting stuck

When I want it to move anything longer than 500mm it gets stuck.

Reduce your max speed. I think somewhere they suggested limiting to no more than 800 vs the 1000 that is the default.


The speed does not change and every time I click save it goes back to the original numbers

I am on the same page as you.

I had issues with my Z and Y axis movement but I’ve sorted that all out now.

My last issue is getting full range moment out of the X axis.

I was informed that maybe it’s because the Stepper Drivers on the RAMPS board are not putting out enough current to fully move the X axis. I tried to move the little screw on the stepper drivers to the right ( at this point I haven’t been able to figure out which direction actually increases the voltage) with no improvement.

have you made any progress @Joelrp84?

Ugh! I tried upping the amps in the stepper drivers using instructions I found on the Polulu website. Unfortunately I fried one of my stepper drivers. I purchased new drivers and popped them on the Ramps board. Now nothing works!!! The Robot synchs, but nothing happens.

I tried a new Arduino and new Ramps board. Still no luck! I have another Pi. I’m pretty sure my Raspberry pi works. Does anyone have any code that I can use to test the individual features of the arduino and RAMP shield features separately. I don’t want to buy yet another round of boards until I figure out what is going wrong. Any help is appreciated.

aw man that’s a freakin bummer. I’m sorry to hear that.

I tried messing with my stepper drivers also and noticed that when I turned the screw and tried to move the Y axis the motor would kick on and run but it didn’t actually move, almost as if the motor kicked on, had power to the motor but couldn’t move the track. oddly enough turning the screw left or right had no variable effect.

Best of luck to you @flavkirst

Report back if you make any progress!

So I have come up with the wires for the X are too heavy so you must slow the movement down to 600. Y and Z down to 800 just because there is no reason to move so fast. I think farmbot is working on the web app and will be fixing the problem with not being able to save the speed settings.