X axis not working properly

We have FarmBot Genesis v1.4 running FARMBOT OS Version 8.2.3. We have few troubles with our X axis not working properly.

  1. X axis calibration doesnt work. It goes from one side to the other and back (it looks like calibration is finished) but then we get Error writing firmware parameter: movement_axis_nr_steps_x: :configuration

2.Our X axis moves smoothly during calibration( but then if we try to move X Axis(in sequence or absolutely) we get Movement failed. Retrying up to 2 more time(s) . It moves a bit 2 times but then we just get error.

Thanks a lot for any suggestions.

Hi @MarHell,

I’m also going through the same stage of setting up the Farmbot and trying to get it ready to work, but since I’ve faced similar problems than yours, I might be of help.

Could you post a screenshot of your hardware parameters? The more detail, the better, so we can all see how to help you.


1 Like

Currently looks like this. We tried many different options but somehow nothing seems to work for us.


Second part here.

Hi @MarHell

Thanks for sharing your hardware parameters. I’m very far from being an expert, but hopefully some of these comments might be of help:

1 - Is there a particular reason why you set the X axis to don’t stop at home? I would keep it on “Yes” to avoid getting unwanted E-stops after the Farmbot tries finding home every time.

2 - Is there a particular reason why you set it to find home on boot only for the X axis? In my experience, I always set this option to NO, since once it’s properly calibrated, finding home every time you turn the FB on might result in getting a different location for your home. Remember that finding home is not the same as going home.

3 - Try increasing your Timeout after values. When I was running calibrations for the first time, the FB stopped for no reason during calibration and I later realised (thanks to help posted in the forum) that it was due to that time “running out”. I set mines to 400 seconds just in case and never had a problem again.

4 - You mention that during a sequence, when you get the Movement failed… message, the FB tries two times and then it stops. This seems to match your Max Retries parameter. Try setting it to 3 times as a start and see if the FB now tries moving 3 times before it E-stops, so you can identify why is it stopping after two retries.

5 - If what I’ve mentioned in point 4- is true, then your problem might be related to the following:
You have your Invert motors parameter for your X motor set to NO. But the same parameter for your 2nd X motor is set to YES.
If I’m right, then this means that your gantry, when trying to move in the X direction, is having one motor trying to go one way and the other motor trying to go the opposite way. This always makes the FB stop, eventually, since it won’t move.
So just leave the Invert motors parameter for both X motors in the same option and you might find a solution for your issue.

If none of these things help, we must keep trying until we find the way out!



None of these ideas seem to work, but thanks to them we found out that our motors somehow miss steps. Thats why we get the Movement failed error. Our calibration finally writes correct X-Axis length ( we adjusted Steps per MM) but we still get the same error. Now we just have to find out why we miss steps. When we adjust MAX MISSED STEPS from 5 to 100 it somehow works but it takes a long time for it to stop on the end of a line. Any ideas why that could be hapenning? Our belt seems to be properly stretched.

Thanks a lot and greetings from Czech Republic.