Y axis no longer moving

Hi everyone, my Y axis motor has stopped moving smoothly. My watering sequence failed, with a movement error on the Y axis. I initially eliminated the possibility of any mechanical obstructions to movement, by manually moving the Y axis and making sure that its movement was unobstructed. I then suspected that the problem causing the jerky movement was a failed driver chip on the Farmduino board.
Initially I caused Farmbot confusion, by swapping the Z and Y motor connections, but not the encoders, but I realised my mistake, swapped the encoders over as well, and then tried to move the Y axis. This seemed to work.
I put things back in their original positions and confirmed that I could move the X and Z axis again with smooth motion - I could. The Y axis, however exhibited the same jerky / failed movement that it has had since this issue arose.
I am fairly sure now that I have a failed Farmduino board. What is the procedure from here?

@dmbgo

I will forward this one to the team when they are in the office tomorrow. If possible, I would be interested to see a video of the behavior to get a better picture of what is going on.

Thanks Rick, it’s just speculation on my part, but I think that the Y axis driver is missing a phase. The Y axis, when reconnected to its original plugs etc, tries to move, but needs manual intervention from me (in the form of pushing the axis) to move. If I tell it to move say 100mm, then provide some pushing help, it thinks it has moved on its own, and is happy.

Regards

David Maher


As youcan see by the settings, I have reduced the movement speed of the Y axis, from originally the same settings as the X axis.

@dmbgo thanks for investigating and eliminating the chance this is a problem with the motor or the cabling. It does sound like it could be a problem with the stepper driver and/or the electronics board.

Which version of the FarmBot do you have? One more thing to check is the MOTOR CURRENT for that axis. If you have a Genesis v1.5 kit with the Trinamic drivers, try increasing the motor current to 1200 or even 1500 and let us know if that helps.


As you can see by the screenshot @roryaronson, I had already tried increasing the Y axis motor current.
The Farmbot is Ver 1.5.
It has been through 2 x mainboards now, the first one was the older noisy type with the replaceable stepper driver chips. The currently failed one is the upgraded version that I bought from you a couple of years ago.
Here is the video of the motor trying to move that @RickCarlino asked for:


2nd try with the recalcitrant video:

The last thing I can recommend trying is resetting all of that axis’ settings to the default values. If that doesn’t help, then we can send you a replacement board. Please just email contact@farm.bot and reference this forum thread and your original order number and we’ll have a replacement sent your way.

Thanks Rory, I have tried what you suggested, with no real change. I have emailed you at contact@farm.bot.
Dave

Thank you for your support and troubleshooting my issue Rory and Marc. It looks like the issue is a faulty on board driver chip for the Y axis. I also see that you have already sent me a replacement board and I am very grateful for this.
Thanks again for your help
Dave

1 Like