Z-axis motor movement

I’m working with a 1.2 kit that I just recently got fully assembled. I have the x and y axis motors working properly but I’m having issues with the z-axis and looking for some additional troubleshooting steps. I’ve searched the forums and gone through the troubleshooting guides and I’m stuck. The observed symptom is when attempting to engage the z-axis motor it clicks and then times out. Here’s what I’ve done so far:

Swapped z and y motors and verified both motors work, problem persists on z-axis
Swapped stepper drivers z and y and problem persists on z-axis
Swapped motor cables z and y and problem changes to y-axis (z-axis moves)
Tried adjusting the z-axis stepper driver power output to no effect

It seems like I can’t get a motor to work when it’s plugged into the z-axis power. Would this then be a problem with the RAMPS shield? Next step buying a new RAMPS shield?

Have you tried:

  • swapping stepper drivers?
  • making sure the RAMPS shield is firmly attached to the Arduino?

Based on the information you provided, the issue could be in the stepper driver, the RAMPS shield, or the Arduino. Nice work isolating the issue so far.

Hi Gabriel,

I have tried swapping the stepper drivers. I edited it in the steps I mentioned above, I tried that after swapping the motors. The RAMPS shield is firmly attached and all motors appear to be worked except the z-slot.

Guess I’ll buy a new RAMPS and try that next.

So you connected the wire that comes from Z axis to the Y-connection on RAMPS board?
-> Could be a problem on the RAMPS shield, or the arduino pins itself. Maybe you can see any heat damage on the connectors at one of those devices.

I would also try to completely unplug ramps from the arduino and plug it back again. Sometimes when I disconnected those two I got similar issues caused by bad connections. Would be really sad if there is only a connection issue and you buy new boards :frowning:

I would recommend examining the connectors at each end of the driver cables and verify that the wires are in the correct position. One of my cables had an incorrect pinout and I had to manually lift the pin and move it to the correct location.