Z-Height, Safe Travel and z-Zero

I need some help with my z-axis. I’m still in the process of setting the system up for the first run of things, and it’s unclear if I have things calibrated. here’s are my question:

1. Where should the UTM be when z is set at zero? All the way at the top of the z axis, or all the way at the bottom? Right now, it is set at the bottom (soil level) But this bumps into things when it does the auto homing. Shouldn’t it be at the top? In that case, do I need to invert the motor directions on the Z axis? What set up do I need to do to prevent it from doing this when homing?

  1. Safe Z and points: I’m trying to set up a grid of points to take photos of the whole bed. But the z-axis is always set to zero for the entire grid - When I group them, I have to go into each point and manually change the z on the point.
  2. Does Safe Z over-ride other travel commands? Or do I have to set it on all my move commands? I’m not really seeing it behaving predictably.

Thanks in advance!

Some users have set soil height to 0, but I highly discourage this. You should set 0 to gantry height and the coordinates should go negative as you get closer to the soil. There are a lot of assumptions baked in to FBOS surrounding this (and it will be compounded further when we release some planned features). My advice is to always enable NEGATIVE COORDINATES ONLY for the Z axis.

As an example, on my FarmBot setup, seeds go into the ground at around Z = -360.

The easiest way to fix this is to delete the whole grid and start over. Be sure to set the Z height before changing the grid parameters.

The Safe Z setting is local to the MOVE block. It is not a global setting and you will always need to check the box if you want to travel with SAFE Z enabled.

Thanks for this, Rick. Much appreciated.

Regarding Z-home, It seems to be automatically set to soil height. What I mean is, when I click the “Find home Z” button, home is located at the bottom, not the top. Does this mean the motors are not calibrated correctly? - Should I invert the motors?

Regarding the points on a grid, I have tried setting the z-height in the top box first, but after then creating the grid, I find that the grid points are set to z= 0. Here are the screenshots of the process;

Step 1: set the z height of the single point, then create the grid.


Step. 2: review the points; in this case there are 30 points in the grid


Step 3: Z is set to “0” for all the points.


What am I doing wrong? Could this be because z-home is set in the wrong spot (but this doesn’t make sense to me since it should just repeat the value, regardless of where the home is.


1 Like

@RickCarlino Seems like the upper part of the points panel is only used for creating single points. Providing a value in the marked Z input box does not affect the grid function at all. I didn’t look at the code yet, but its behaving like this on my device. It would be probably best to add another Z input field and also another AT SOIL LEVEL checkbox on the grid section.
@AidanJ thanks for the detailed report, was able to reproduce it easily :slight_smile:

1 Like

Thanks Ascend - I wonder who else is affected.

A quick update. I was able to get into school today and set the Enable negative coordinates for the Z-Axis. I’ve solved my homing/crashing issue. For newbies like me, this seems like an extra step - it would be clearer if this setting was automatically set during the setup procedures. I also noticed that the homing animations on the site also show the z-axis homing at the bottom of the gantry, not at the top. I agree with you Rick, it makes sense to be working in negative values for the -axis. Perhaps the next round of documentation can make that clearer?

Thanks for everyone’s help so far.


Can you fully power cycle the device and see if that helps? There was a firmware bug (which will be fixed in the v14 release) where sometimes firmware settings would “linger” after being changed. We can remotely inspect your device if that still doesn’t help- this sounds like a simple configuration issue, though.

Apologies, memory might not be serving me correctly on this one! I will take a deeper look on Monday to see if something has changed recently in the point grid creation panel. Setting Z-depth is not something I typically do when working with point grids because of the OVERRIDE and OFFSET features of the MOVE block (described below).

Essentially, you create the grid as usual and then OVERRIDE the Z value in the sequences.

For example, if you wanted the grid to have a Z height of -200:

This is helpful because you can change the Z height as plants grow. The example above illustrates how I do most operations on my FarmBot. Alternatively, you could use an OFFSET from 0. Either approach gives you the ability to modify the height of a grid when performing operations.

Negative coordinates are the default for new FarmBot accounts. I just created a new account to verify this. Since you mention that your device is located in a school, is it possible someone else accidentally changed this setting?

If you are ever unsure if a setting is set to the default or a non-default, you can look for a “yellow halo” around the setting. In the example below, you can see which setting has a default (vs. non-default) setting:


Axis homing depends on how the user has set up their device, though I might be misunderstanding the issue- please let me know if that’s the case! :sweat_smile:

Setting the MAP ORIENTATION may help:


Does that help at all ? Please let me know if not.

Additionally, if you need more help setting your device up, you can email contact@farmbot.io for calibration assistance.

Thanks for this Rick, Everything is set correctly. Much appreciated. my colleague and I misinterpreted the animations to show from a side view, not top-down view. I think that led to our confusion.

Thanks again for your help.