Camera problems


#1

I was able to take photos with the camera when I first got started, but since 3.1.4 or 3.1.5, the camera selection reverts back to none. Sometimes I get the message “Done” next to Select a camera… but other times I just get the message “error.”

Today I was able to run a sequence with take-photo, but only a solid black photo shows up in my feed. After running the sequence I get this message in the log: PACO [TAKE-PHOTO] SELECT TIMEOUT (Paco is what I call my bot). Any ideas?


Troubleshooting Failed Movements
#2

Do you have any other devices plugged into the USB ports of the Pi besides the camera and the arduino?

When you look at the photos on the web site, have you scrolled back/forward to see if maybe they are out of order?

FWIW, my camera selection has always reverted back to “none” after picking. It doesn’t really seem to care.


#3

To troubleshoot the SELECT TIMEOUT issue, try unplugging the camera and plugging it back in.


#4

Thanks @Gabriel , I’ll give it a try tomorrow.

@bgmoon, I don’t have any other devices plugged in, although I have moved them around. And yes, I’ve flipped through the photos and checked the dates. The two from today have the correct date and times on them but are just black. I am glad I’m not the only one with the camera: none issue; thanks for the feedback!


#5

Similar problems here, I wanted to select the camera yesterday and sometimes it said done
but then the selection went back to none. However I could take pictures, but need to spend more time on that…
Using 3.1.6…


#6

If the “done” message is displayed, the camera selection was successful.


#7

@bonanzajellydog are you still having the same issue with black photographs? I’m experiencing the same thing. Did you ever find a fix?


#8

We are using OS 4.0.1 and still getting intermittent issues taking pictures. Says camera error but it worked,


#9

Have you tried unplugging the camera and plugging it back in or rebooting?


#10

I have a same problem.Have been successful before,I also keep plugging and pulling, but it’s not useful.


#11

Hi @Gabriel - not tried unplugging the camera (but it was working more reliably on earlier versions).
Tried a soft restart.


#12

hi guys, i still dont connect camera to take photo as kimptoc and xiaorong. Because i dont know install farmware. i hope everybody can show me a solution.


#13

The Take Photo farmware installs on boot, so if it’s not installed you can try rebooting.


#14

plugging usb camera after that i can use camera to take photo?


#15

All, I’m using 4.0.1 of the fw/sw/os. I too am having issues with the camera: specifically the images will never appear in the web portal. I’m not getting any errors per se, so I’m not sure where to go from here. Any thoughts will be welcomed


#16

We have fixed an issue related to image uploading, please try taking a new photo.


#17

Thanks Gabriel! It’s working now.


#18

My USB camera is also a problem, I plug my camera is on the raspberry pie, I am using version 4.0.1 system, but can’t take photos, thank you for always to my counsel.


#19

I am also getting this error xiaorong. I’ve tried unplugging the camera from the pi and moving it to a different USB port. Also tried a restart. But just get the same error in your screen shot when I try to set the USB Camera on the device page.

Has anyone managed to solve it or have any ideas why it’s happening?


#20

What message do you get when you set the camera type on the Device page? What happens when you try to take a photo?