Camera problems


#21

I am just about setting up my farmbot and I run into the same camera issue. I just can’t get the USB camera to work. Any progress with this issue yet?


#22

@derletztename Can you give us more information how your system reacts after clicking the take photo button? Are there any logs or error messages displayed?


#23

Sure. Thx for the fast response. After clicking the “take photo” button the system does nothing visible for quite some time and then this error message pops up. Sorry that it’s german, but I guess you can still understand it


#24

Sounds like the process is aborted due to a timeout. I assume you are using the borroscope from the official kit. Did you try to select the camera in the device widget (popup message should confirm) and try again? Also connecting to another USB port and restart helped sometimes.

Don’t worry, I’m German myself and even made the translation :slight_smile:


#25

So I tried again with Edge and now I got another message:
grafik

I am not using the original borroscope camera but just some logitech webcam for testing.
Btw it’s english in edge and partly german in Firefox. I have no idea why though

Do I have to mount the usb camera somehow in the Pi? Or should it automatically recognise the port?


#26

Huh alright, maybe @Gabriel got more insight in USB cameras? My USB camera is working properly right after plugging. Maybe there are different types of cameras (drivers, communication etc.)?

Looks like edge is blocking the language resource because of a violated “Content-security-policy”. This is probably something you can’t fix yourself, I would recommend to use Google Chrome if you need the webapp translated.

Just plug it in, restart everything (unplug, and plug it back in) and select the camera. It doesn’t matter which port it is plugged in, it will recognize itself.


#27

I bought a new Microsoft webcam I can use for web conferences anyway and with that it’s working. So somehow the issue was related to the old Logitech camera I’ve used for testing.
So issue solved (for me at least).


#28

3 posts were split to a new topic: Uploading photos to self-hosted local server


#29

Like others on this thread I am now getting a black frame instead of an image. Did other people in this thread find a solution?

Thanks,


#30

Didn’t you get an error message saying couldn’t take photo? Have you activated the error log?

Last thing I heard was a strong vote for a usb driver problem. Unplugging and plugging in again seemed to help… I wonder when the FB team will have something official for us… @Gabriel?


#31

@Gabriel @connor the black image upload problem persists and is not solved; have you any idea what you can do more to fix it?


#32

This is a problem with v4l drivers and opencv’s python api from what i remember. I’ve never hit this issue myself personally, but i’ve seen unplugging and replugging the camera in helps/fixes it.


#33

@connor I will definitely not unplug the cam each time this error happens, you need to provide a proper fix!


#34

Anymore ideas @connor how you could software wise tackle this problem?


#35

I don’t know enough about OpenCV’s Python API. (what we currently use to take photos). I do know that 1) no one at FarmBot Inc has had this issue, so it is difficult for us to test fixes. 2) it is likely not a hardware issue. We are still investing ways to handle this problem via software.


#36

I have the same error with “getting image” and I’m pretty sure I have fixed it by replacing the right-angle USB extension cable. I hooked up the usb cable to a laptop which saw the camera right away when that cable was not part of it.