Detecting available UARTs: [“ttyACM0”, “ttyAMA0”]

Having issues with my Farmbot that I’ve never had before. I’ve been running my FB successfully for a couple years now…never had this type of issue. Doing a watering sequence (Like I’ve done many many times before) and there is a 50/50 chance it will make it. Sometimes it waters all 24 plants and other times it crashes after watering 10 plants. I’ve includes a screen capture of my logs. Running current firmware Version 14.6.3.

Any ideas?

Taking a look now @socalrob


Thanks Rick!

@socalrob It appears that your firmware is timing out for some reason. I am going to publish a new version of FBOS to see if it fixes the issue. Please leave your device online so that I can flash the beta version onto the device.

Thanks Rick…I will leave it online!

@socalrob Can you please perform a hard reflash of FBOS? Aside from the timeouts, it looks like your device is also overheating and is no longer talking to the message broker.

Hi Rick, I’m at work right now, but I’ll do a hard reflash of FBOS when I get home.
That sounds worrisome about overheating. Any ideas why it might be overheating and could this possibly fry the board???

@socalrob It’s nothing too serious- usually it is just a sign that something is causing the CPU to work too hard. I will take a deeper look after you perform a hard re-flash.

Okay, that’s good to know! I’ll have the hard reflash done in about 3 hours from now. Thanks for your quick response and help with this Rick. Always great service from you and your team!!!

1 Like

No problem, @socalrob ! Happy to help. It appears that your bot is offline at the moment. I can take a deeper look when it is back online again.

Hi Rick, take a look at the photos. When I got home from work last night,

I discovered why it was overheating…apparently it went into “Trench Digging” mode (New feature LOL?) until it finally crashed into the far corner. I was not able to get it connected last night. I did hard flash on the SD card and I still could not connect. I’ll have to try and solve the connection issue again tonight (Ran out of time last night)

Uh oh! :man_facepalming: I tried to reproduce the error by running a sequence against untitled group- looks like the motors were not properly homed at the time of execution. Sorry about that!

I don’t think this would have been a cause of the CPU running hot, but please do let us know if you need any assistance getting it back up and running.

1 Like

Thanks Rick!

How are things looking @socalrob ?

Hey Rick, thank you for following up with me on this. I worked on it for a couple hours last night. Now I cannot get it reconnected to my Wi-Fi. I have a top of the line Eero Pro 6 Mesh system running WiFi 6 at 5GHz but for some reason my Farmbot is having trouble connecting. I did several hard re-flashes. It shows a weak signal on the Configure FarmBot 14.6.4. I was able to reconnect momentarily during set-up, but I could never open the actual APP. My Wi-Fi node is only 15 to 20 feet away. I have outdoor Lutron and Ring devices that are further away and their connection is VERY strong…no issues. I can send you screen shots of this if it will help. Does FarmBot have any issues with Wi-Fi 6 and/or 5Ghz? Any ideas? I really appreciate all your help with this!! Anxious to get my FB back up and running!

Hi @socalrob

Connections to this router have been working Ok for the bot until recently ?

Assuming your bot is a Genesis model, yes, the Linux buildroot kernel for the Raspberry Pi model 3 does not yet support all Wi-Fi 6 features, in particular, WPA3 security.
Maybe check that the Eero Pro is configured to allow WPA2 on the SSID used for the bot.

5 GHz channels should be fine provided that you’ve set up your Wireless Regulatory Domain Country Code correctly during Configuration.

[edit] Just checked my Express bot and discovered that the Raspberry Pi Zero W in there is set to Wi-Fi Generation 4 ( hw_mode N ) :slight_smile: :

iex(farmbot@farmbot-84e5.local)5> cmd 'wpa_cli -p /tmp/vintage_net/wpa_supplicant status'
Selected interface 'wlan0'

Hi @jsimmonds
Yes, I have a Genesis v 1.5. It was connecting fine on version 14.6.1. However, I was having problems with it stalling randomly. After I did an update (Hard flash on the SD card as well), it would not connect again. I’ll check on the configuration tonight when I’m off work. Thanks for your suggestion. I am running several other wireless devices nearby that have no issues with connection whatsoever (Showing a strong connection). Farmbot was showing a weak connection. I appreciate your ideas!!

Hey @RickCarlino
Here is a screen shot if this helps in any way…

@socalrob If you are using the exact same wifi router as before, then I think it would be unlikely that the router is the problem. We have seen that some routers need to be put into “legacy mode” in order to function properly, but again, that would seem unlikely if it was working a week ago with the same wifi settings.

More likely is that the device hit an issue during configuration.

  • If you put a bad WiFi password, the device will go back into the configurator (sometimes requires a power cycle)
  • If you put in bad account credentials (such as accidentally capitalizing a letter in the password, accidental space, etc…) configurator may not come up again and the device will show as offline.

Some things to try:

  • If you know how to do a WiFi network device scan (using tools like Fing for Android), you can check to see if FarmBot is on the LAN. If you see it on the LAN, but it is not showing as online, there is almost certainly an account credentials typo. This would also mean that there is no issue with your router. A hard re-flash is required.
  • Check your WiFi router’s configuration menu to see if it supports a “legacy support mode” (unlikely, but it might be worth a look).
  • Power cycle the device to see if the configurator comes back online. If that is the case, it is likely a problem with WiFi configs.

Please let me know if either of those things help. If not I may move the discussion to a private message to see if there is something that is device-specific going on.


I totally agree with Ricks suggestions about what might help. But keep in mind, that the Raspberry 3b does only use the 2.4Ghz WiFi band, while the newer 3b+ can use dual band (2.4Ghz and 5Ghz). It looks like the v1.5 devices that were shipped after 1st November 2020 should have the 3b+.